summaryrefslogtreecommitdiffstats
path: root/src/fan/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/fan/CMakeLists.txt')
-rw-r--r--src/fan/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/fan/CMakeLists.txt b/src/fan/CMakeLists.txt
index 16c6e18..7cb801a 100644
--- a/src/fan/CMakeLists.txt
+++ b/src/fan/CMakeLists.txt
@@ -1,6 +1,6 @@
set(PROVIDER_NAME Fan)
-set(LIBRARY_NAME cmpiCura_${PROVIDER_NAME})
+set(LIBRARY_NAME cmpiLMI_${PROVIDER_NAME})
set(MOF LMI_Fan.mof)
set(provider_SRCS
@@ -21,10 +21,10 @@ add_library(${LIBRARY_NAME} SHARED
include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR})
-target_link_libraries(${LIBRARY_NAME} curacommon ${KONKRETCMPI_LIBRARIES} sensors)
+target_link_libraries(${LIBRARY_NAME} openlmicommon ${KONKRETCMPI_LIBRARIES} sensors)
# Create registration file
-cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/cura-providers)
+cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers)
install(TARGETS ${LIBRARY_NAME} DESTINATION lib${LIB_SUFFIX}/cmpi/)