summaryrefslogtreecommitdiffstats
path: root/src/account/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/account/CMakeLists.txt')
-rw-r--r--src/account/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/account/CMakeLists.txt b/src/account/CMakeLists.txt
index 7aa517e..2c1d817 100644
--- a/src/account/CMakeLists.txt
+++ b/src/account/CMakeLists.txt
@@ -5,8 +5,17 @@ set(MOF LMI_Account.mof)
set(provider_SRCS
aux_lu.c
+ account_globals.c
)
+if (NOT DEFINED CRYPT_ALGS)
+ message ("Setting default crypto algorithms")
+ set (CRYPT_ALGS "\"DES\"")
+endif (NOT DEFINED CRYPT_ALGS)
+
+message ("Using crypto algorithms: ${CRYPT_ALGS}")
+add_definitions(-DCRYPT_ALGS=${CRYPT_ALGS})
+
konkretcmpi_generate(${MOF}
CIM_PROVIDERS
CIM_HEADERS