summaryrefslogtreecommitdiffstats
path: root/openlmi-providers.spec
diff options
context:
space:
mode:
Diffstat (limited to 'openlmi-providers.spec')
-rw-r--r--openlmi-providers.spec11
1 files changed, 11 insertions, 0 deletions
diff --git a/openlmi-providers.spec b/openlmi-providers.spec
index 0dd18ab..d57610b 100644
--- a/openlmi-providers.spec
+++ b/openlmi-providers.spec
@@ -82,6 +82,8 @@ BuildRequires: pciutils-devel
# For openlmi-logicalfile
BuildRequires: libudev-devel
BuildRequires: libselinux-devel
+# For openlmi-realmd
+BuildRequires: dbus-devel
# For openlmi-mof-register script
%if 0%{?suse_version}
BuildRequires: python
@@ -505,6 +507,7 @@ pushd src/software
install -m 755 -d $RPM_BUILD_ROOT/%{_libexecdir}/pegasus
install -m 755 pycmpiLMI_Software-cimprovagt $RPM_BUILD_ROOT/%{_libexecdir}/pegasus/
popd # src/software
+cp mof/LMI_Software.reg $RPM_BUILD_ROOT/%{_datadir}/%{name}/
# pcp
pushd src/pcp
@@ -928,6 +931,14 @@ if [ "$1" -ge 1 ]; then
%{_datadir}/%{name}/90_LMI_Hardware_Profile_DMTF.mof || :;
fi >> %logfile 2>&1
+%post -n openlmi-pcp
+if [ "$1" -ge 1 ]; then
+ %{_bindir}/openlmi-mof-register -v %{providers_version} register \
+ %{_datadir}/%{name}/60_LMI_PCP.mof \
+ %{_localstatedir}/lib/%{name}/60_LMI_PCP_PMNS.mof \
+ %{_localstatedir}/lib/%{name}/60_LMI_PCP_PMNS.reg || :;
+fi >> %logfile 2>&1
+
%post -n openlmi-journald
if [ "$1" -ge 1 ]; then
%{_bindir}/openlmi-mof-register -v %{providers_version} register \