summaryrefslogtreecommitdiffstats
path: root/src/libs/indmanager/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Synacek <jsynacek@redhat.com>2014-05-06 11:09:17 +0200
committerJan Synacek <jsynacek@redhat.com>2014-05-06 11:09:17 +0200
commitc6cbafa06ccee8d12163b5eeac97fc2adc542668 (patch)
treeaa326733674ba4131f85b1f4550ea111d8022f7f /src/libs/indmanager/CMakeLists.txt
parentcf62127392299d74326717acf884ce249f25afe4 (diff)
downloadopenlmi-providers-c6cbafa06ccee8d12163b5eeac97fc2adc542668.tar.gz
openlmi-providers-c6cbafa06ccee8d12163b5eeac97fc2adc542668.tar.xz
openlmi-providers-c6cbafa06ccee8d12163b5eeac97fc2adc542668.zip
indmanager: move to libs
Diffstat (limited to 'src/libs/indmanager/CMakeLists.txt')
-rw-r--r--src/libs/indmanager/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/libs/indmanager/CMakeLists.txt b/src/libs/indmanager/CMakeLists.txt
new file mode 100644
index 0000000..3a265c9
--- /dev/null
+++ b/src/libs/indmanager/CMakeLists.txt
@@ -0,0 +1,19 @@
+add_library(openlmiindmanager SHARED
+ ind_manager.c
+)
+
+set(OPENLMIINDMANAGER_VERSION_MAJOR 1)
+set(OPENLMIINDMANAGER_VERSION_MINOR 0)
+set(OPENLMIINDMANAGER_VERSION_PATCH 0)
+set(OPENLMIINDMANAGER_VERSION "${OPENLMIINDMANAGER_VERSION_MAJOR}.${OPENLMIINDMANAGER_VERSION_MINOR}.${OPENLMIINDMANAGER_VERSION_PATCH}")
+
+set_target_properties(openlmiindmanager PROPERTIES VERSION ${OPENLMIINDMANAGER_VERSION})
+set_target_properties(openlmiindmanager PROPERTIES SOVERSION ${OPENLMIINDMANAGER_VERSION_MAJOR})
+
+target_link_libraries(openlmiindmanager pthread)
+
+install(TARGETS openlmiindmanager DESTINATION lib${LIB_SUFFIX})
+install(FILES ind_manager.h DESTINATION include/openlmi)
+
+configure_file(openlmiindmanager.pc.in ${CMAKE_CURRENT_BINARY_DIR}/openlmiindmanager.pc @ONLY)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/openlmiindmanager.pc DESTINATION lib${LIB_SUFFIX}/pkgconfig)