summaryrefslogtreecommitdiffstats
path: root/src/fan/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Safranek <jsafrane@redhat.com>2013-07-26 13:16:49 +0200
committerJan Safranek <jsafrane@redhat.com>2013-07-26 13:16:49 +0200
commita7aceca037e88bb6d8a2d14641742df8d9e9c627 (patch)
tree4ba392d2e93651de1909cd0f532609010ccd4455 /src/fan/CMakeLists.txt
parenteddd9e5d1b97be919e7cad7a62bc7316898f4a68 (diff)
downloadopenlmi-providers-a7aceca037e88bb6d8a2d14641742df8d9e9c627.tar.gz
openlmi-providers-a7aceca037e88bb6d8a2d14641742df8d9e9c627.tar.xz
openlmi-providers-a7aceca037e88bb6d8a2d14641742df8d9e9c627.zip
Added cimprovagt wrapper for Fan profile.
Diffstat (limited to 'src/fan/CMakeLists.txt')
-rw-r--r--src/fan/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/fan/CMakeLists.txt b/src/fan/CMakeLists.txt
index 0028997..7c17f50 100644
--- a/src/fan/CMakeLists.txt
+++ b/src/fan/CMakeLists.txt
@@ -2,6 +2,7 @@
set(PROVIDER_NAME Fan)
set(LIBRARY_NAME cmpiLMI_${PROVIDER_NAME})
set(MOF 60_LMI_Fan.mof)
+set(FAN_SCRIPT cmpiLMI_${PROVIDER_NAME}-cimprovagt)
set(provider_SRCS
fan.c
@@ -31,3 +32,4 @@ profile_mof_generate("90_LMI_Fan_Profile.mof.skel" "${TARGET_MOF}" "${CIM_CLASSE
install(TARGETS ${LIBRARY_NAME} DESTINATION lib${LIB_SUFFIX}/cmpi/)
install(FILES ${TARGET_MOF} DESTINATION share/openlmi-providers/)
+install(PROGRAMS ${FAN_SCRIPT} DESTINATION libexec/pegasus)