summaryrefslogtreecommitdiffstats
path: root/openlmi-providers.spec
diff options
context:
space:
mode:
authorMichal Minar <miminar@redhat.com>2013-08-27 14:39:03 +0200
committerMichal Minar <miminar@redhat.com>2013-08-28 08:44:53 +0200
commit47c57bad255ba7fdd91b73b527a8e93d1d220ebf (patch)
tree13bceeab88054e69397ebff0c014061460071a4e /openlmi-providers.spec
parent74fb3cb4a410cd5650928de0e855dcaa6f7c83c1 (diff)
downloadopenlmi-providers-47c57bad255ba7fdd91b73b527a8e93d1d220ebf.tar.gz
openlmi-providers-47c57bad255ba7fdd91b73b527a8e93d1d220ebf.tar.xz
openlmi-providers-47c57bad255ba7fdd91b73b527a8e93d1d220ebf.zip
spec: added account documentation subpackage
New subpackage: openlmi-account-doc containing admin guide Also added missing dependency for openlmi-providers-devel subpackage, which was missing konkretcmpi-python in its Requires. It needs to be present for openlmi-doc-class2rst script to work properly.
Diffstat (limited to 'openlmi-providers.spec')
-rw-r--r--openlmi-providers.spec25
1 files changed, 24 insertions, 1 deletions
diff --git a/openlmi-providers.spec b/openlmi-providers.spec
index 122b169..6bedb37 100644
--- a/openlmi-providers.spec
+++ b/openlmi-providers.spec
@@ -1,4 +1,5 @@
%global logfile %{_localstatedir}/log/openlmi-install.log
+%global required_konkret_ver 0.9.0-2
Name: openlmi-providers
Version: 0.1.1
@@ -14,7 +15,7 @@ Provides: cura-providers%{?_isa} = %{version}-%{release}
Obsoletes: cura-providers < 0.0.10-1
BuildRequires: cmake
-BuildRequires: konkretcmpi-devel >= 0.9.0-2
+BuildRequires: konkretcmpi-devel >= %{required_konkret_ver}
BuildRequires: sblim-cmpi-devel
BuildRequires: cim-schema
# For openlmi-power
@@ -24,6 +25,9 @@ BuildRequires: lm_sensors-devel
# For openlmi-account
BuildRequires: libuser-devel
BuildRequires: python2-devel
+# for openlmi-account-doc
+BuildRequires: konkretcmpi-python >= %{required_konkret_ver}
+BuildRequires: python-sphinx
# For openlmi-hardware
BuildRequires: pciutils-devel
# For openlmi-logicalfile
@@ -55,6 +59,7 @@ Model (CIM).
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
+Requires: konkretcmpi-python >= %{required_konkret_ver}
Provides: cura-providers-devel%{?_isa} = %{version}-%{release}
Obsoletes: cura-providers-devel < 0.0.10-1
@@ -104,6 +109,14 @@ Obsoletes: cura-account < 0.0.10-1
%description -n openlmi-account
%{summary}.
+%package -n openlmi-account-doc
+Summary: CIM account provider documentation
+Group: Documentation
+BuildArch: noarch
+
+%description -n openlmi-account-doc
+This package contains the documents for OpenLMI account provider.
+
%package -n openlmi-hardware
Summary: CIM provider for hardware on system
Requires: %{name}%{?_isa} = %{version}-%{release}
@@ -230,6 +243,9 @@ pushd src/pcp
%{__python} setup.py build
popd
+# documentation
+make -C src/account/doc html
+
%install
make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
@@ -271,6 +287,9 @@ sed -i -e 's,^_LOCALSTATEDIR=.*,_LOCALSTATEDIR="%{_localstatedir}",' \
$RPM_BUILD_ROOT/%{_sysconfdir}/cron.daily/openlmi-pcp
mkdir -p $RPM_BUILD_ROOT/%{_localstatedir}/lib/%{name}
+# documentation
+install -m 755 -d $RPM_BUILD_ROOT/%{_docdir}/%{name}/account/admin_guide
+cp -pr src/account/doc/build/html/* $RPM_BUILD_ROOT/%{_docdir}/%{name}/account/admin_guide
%files
%doc README COPYING
@@ -326,6 +345,9 @@ mkdir -p $RPM_BUILD_ROOT/%{_localstatedir}/lib/%{name}
%{_datadir}/%{name}/90_LMI_Account_Profile.mof
%attr(755, root, root) %{_libexecdir}/pegasus/cmpiLMI_Account-cimprovagt
+%files -n openlmi-account-doc
+%{_docdir}/%{name}/account/admin_guide
+
%files -n openlmi-hardware
%doc README COPYING
%{_libdir}/cmpi/libcmpiLMI_Hardware.so
@@ -696,6 +718,7 @@ fi >> %logfile 2>&1
%changelog
* Tue Aug 27 2013 Michal Minar <miminar@redhat.com> 0.1.1-3
+- Added openlmi-account-doc package with admin guide.
- Fixed installation of python packages.
* Wed Aug 14 2013 Jan Safranek <jsafrane@redhat.com> 0.1.1-2