summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Safranek <jsafrane@redhat.com>2013-10-18 14:45:03 +0200
committerJan Safranek <jsafrane@redhat.com>2013-10-18 14:45:03 +0200
commitc15f9ee5a0e25a91781e4c23f1cfb0ca7c5b7336 (patch)
treedc34216411938495b489368e15e22a7e5a5d0878 /CMakeLists.txt
parent087d51a3b03815ddbacaf62bf2fa047dbcbb9537 (diff)
downloadopenlmi-providers-c15f9ee5a0e25a91781e4c23f1cfb0ca7c5b7336.tar.gz
openlmi-providers-c15f9ee5a0e25a91781e4c23f1cfb0ca7c5b7336.tar.xz
openlmi-providers-c15f9ee5a0e25a91781e4c23f1cfb0ca7c5b7336.zip
Rework documentation.
- Everything is in openlmi-providers/doc/admin directory. - 'make doc' automatically builds documentation of all enabled providers. - Documentation shares one 'conf.py' for sphinx. - All documentation uses the same directory structure. There is only one CMakefile.txt to generate all the docs.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 98e726a..024d51a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,7 @@ pkg_check_modules(GLIB REQUIRED glib-2.0)
add_subdirectory(src)
add_subdirectory(mof)
add_subdirectory(tools)
+add_subdirectory(doc)
install(PROGRAMS openlmi-mof-register DESTINATION bin)
install(PROGRAMS openlmi-register-pegasus DESTINATION libexec)