summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Novacek <rnovacek@redhat.com>2012-08-29 09:38:32 +0200
committerRadek Novacek <rnovacek@redhat.com>2012-08-29 10:20:49 +0200
commit7757c0018d8dbaeec3194958b3029d69120ac465 (patch)
tree323f0a09c168b5662f540f08aad9b73eecc907bd /CMakeLists.txt
parenta84a46269b1e4147e31a3233fe3feb0879c268ba (diff)
downloadopenlmi-providers-7757c0018d8dbaeec3194958b3029d69120ac465.tar.gz
openlmi-providers-7757c0018d8dbaeec3194958b3029d69120ac465.tar.xz
openlmi-providers-7757c0018d8dbaeec3194958b3029d69120ac465.zip
Show error when library has undefined symbols
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f56dcf5..f32881d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,7 @@ cmake_minimum_required(VERSION 2.6)
# Set flags and definitions
add_definitions(-D_XOPEN_SOURCE=500 -D_GNU_SOURCE)
-set(CMAKE_C_FLAGS "-std=c99 -Wall -pedantic -g -Wextra -Wno-unused-parameter -Wformat -Wparentheses")
+set(CMAKE_C_FLAGS "-std=c99 -Wall -pedantic -g -Wextra -Wno-unused-parameter -Wformat -Wparentheses -Wl,--no-undefined")
# Set LIB_SUFFIX to 64 on 64bit architectures
if(CMAKE_SIZEOF_VOID_P EQUAL 4)