summaryrefslogtreecommitdiffstats
path: root/collection/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'collection/configure.ac')
-rw-r--r--collection/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/collection/configure.ac b/collection/configure.ac
index 4858bc6..cf7a1ff 100644
--- a/collection/configure.ac
+++ b/collection/configure.ac
@@ -24,5 +24,12 @@ AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TR
AC_CHECK_SIZEOF([long])
AC_CHECK_SIZEOF([long long])
+AC_CHECK_FUNC([strcasestr],
+ AC_DEFINE([HAVE_STRCASESTR],
+ [1],
+ [Define if strcasestr exists]),
+ AC_MSG_ERROR("Platform must support strcasestr"))
+
+
AC_CONFIG_FILES([Makefile collection.pc])
AC_OUTPUT