summaryrefslogtreecommitdiffstats
path: root/elapi/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-10-07 09:45:39 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-10-16 14:27:24 -0400
commit0c1edf81f5da9801c17dc1300053896433e3b885 (patch)
tree32ba182f322830682da9ab3d51f2b3cbe1bf2868 /elapi/Makefile.am
parenta5e2b56bfa2cd183bf071a7d0dc2bad6383781d8 (diff)
downloadding-libs2-0c1edf81f5da9801c17dc1300053896433e3b885.tar.gz
ding-libs2-0c1edf81f5da9801c17dc1300053896433e3b885.tar.xz
ding-libs2-0c1edf81f5da9801c17dc1300053896433e3b885.zip
ELAPI Compatibility code for getifaddr()
Addreses ticket #94 Actually works pretty well. To try use --enable-compat when build ELAPI. It will use compatibility code instead of getifaddr(). The trick in the elapi_ioctl.h with memory allocation is taken from Stevens book.
Diffstat (limited to 'elapi/Makefile.am')
-rw-r--r--elapi/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/elapi/Makefile.am b/elapi/Makefile.am
index 53f2c3e..747a388 100644
--- a/elapi/Makefile.am
+++ b/elapi/Makefile.am
@@ -55,13 +55,17 @@ libelapi_la_SOURCES = \
elapi_resolve.c \
elapi_async.c \
elapi_subst.c \
+ elapi_ioctl.c \
elapi_event.h \
elapi_priv.h \
elapi_sink.h \
elapi_log.h \
elapi_async.h \
+ elapi_net.h \
+ elapi_ioctl.h \
elapi_fd.h \
elapi_tm.h \
+ elapi_defines.h \
elapi.h
libelapi_la_LIBADD = libprovider.la libelapibasic.la