summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-04-06 15:29:07 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-04-06 15:59:21 -0400
commite54786d970c3a4643644b99f7b5f0d4332d7db5d (patch)
tree7bc60b611a3036eb822b63562c9ac2ccff60116a /configure.ac
parentbf2e070c3cd0fa434fe2969844a55f292b26a8ff (diff)
downloadding-libs2-e54786d970c3a4643644b99f7b5f0d4332d7db5d.tar.gz
ding-libs2-e54786d970c3a4643644b99f7b5f0d4332d7db5d.tar.xz
ding-libs2-e54786d970c3a4643644b99f7b5f0d4332d7db5d.zip
Fix build system for Collection and INI parser.
Adds ini subdirectory so it will be built, adds some clarification to the README, makes the configure --help more clear about the trace level and enables -Wall reporting.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 83a2c18..941125d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,13 +11,13 @@ AC_CONFIG_HEADERS([config.h])
# Enable trace build
AC_ARG_ENABLE([trace],
- [AS_HELP_STRING([--enable-trace],[build with low level tracing enabled])],
+ [AS_HELP_STRING([--enable-trace[=LEVEL]],[build with low level tracing enabled])],
[trace_level="$enableval"],
[trace_level="0"])
AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TRACE_VAR],["-DTRACE_LEVEL=$trace_level"])])
-AC_CONFIG_FILES([Makefile collection/Makefile])
+AC_CONFIG_FILES([Makefile collection/Makefile ini/Makefile])
AC_OUTPUT