summaryrefslogtreecommitdiffstats
path: root/collection/configure.ac
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2010-03-05 17:23:00 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-03-08 13:42:47 -0500
commitf50374ed1a3d40a984f2386c05306a7ecdd21e95 (patch)
tree011426d78472eb224cb0b09def40b1ba6066a88f /collection/configure.ac
parentf003197d370bd177027bd7042206892c7ada5771 (diff)
downloadding-libs2-f50374ed1a3d40a984f2386c05306a7ecdd21e95.tar.gz
ding-libs2-f50374ed1a3d40a984f2386c05306a7ecdd21e95.tar.xz
ding-libs2-f50374ed1a3d40a984f2386c05306a7ecdd21e95.zip
Documentation for collection interface
Passed through the interface and changed the comments to comply with the collection interface.
Diffstat (limited to 'collection/configure.ac')
-rw-r--r--collection/configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/collection/configure.ac b/collection/configure.ac
index 2ec6c01..25aba16 100644
--- a/collection/configure.ac
+++ b/collection/configure.ac
@@ -1,4 +1,6 @@
-AC_INIT([collection],[0.4.0],[sssd-devel@lists.fedorahosted.org])
+AC_INIT([collection],
+ [0.4.0],
+ [sssd-devel@lists.fedorahosted.org])
AC_CONFIG_SRCDIR([collection.c])
AC_CONFIG_AUX_DIR([build])
AM_INIT_AUTOMAKE([-Wall -Werror foreign])
@@ -32,6 +34,9 @@ AC_CHECK_FUNC([strcasestr],
AC_DEFINE([COL_MAX_DATA], [65535], [Max length of the data block allowed in the collection value.])
+AC_PATH_PROG([DOXYGEN], [doxygen], [false])
+AM_CONDITIONAL([HAVE_DOXYGEN], [test x$DOXYGEN != xfalse ])
-AC_CONFIG_FILES([Makefile collection.pc])
+
+AC_CONFIG_FILES([Makefile collection.cfg.doxy collection.pc])
AC_OUTPUT