summaryrefslogtreecommitdiffstats
path: root/collection/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-04-06 09:30:01 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-04-06 15:59:21 -0400
commit548fb76622cacbdf4416f07b718f1bdd93924a9f (patch)
tree5b65b939ec4877cbd1e8f3b7a84897bb579eca0a /collection/Makefile.am
downloadding-libs2-548fb76622cacbdf4416f07b718f1bdd93924a9f.tar.gz
ding-libs2-548fb76622cacbdf4416f07b718f1bdd93924a9f.tar.xz
ding-libs2-548fb76622cacbdf4416f07b718f1bdd93924a9f.zip
First commit of basic collection API.
Diffstat (limited to 'collection/Makefile.am')
-rw-r--r--collection/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/collection/Makefile.am b/collection/Makefile.am
new file mode 100644
index 0000000..06cf953
--- /dev/null
+++ b/collection/Makefile.am
@@ -0,0 +1,17 @@
+#DEBUG_FLAGS=@DEBUG_VAR@
+TRACE_LEVEL=@TRACE_VAR@
+
+topdir=..
+AM_CPPFLAGS = -I$(topdir) -I$(topdir)/trace $(TRACE_LEVEL)
+
+# Build static libraty
+noinst_LIBRARIES = libcollection.a
+libcollection_a_SOURCES = collection.c collection_tools.c collection.h trace.h collection_tools.h collection_class.h
+
+# Build shared library - reserved for future
+# lib_LTLIBRARIES = libcollection.la
+# libcollection_la_SOURCES = collection.c collection_tools.c collection.h trace.h collection_tools.h collection_class.h
+
+noinst_PROGRAMS = collection_ut
+collection_ut_SOURCES = collection_ut.c
+collection_ut_LDADD = libcollection.a -lm -lz