summaryrefslogtreecommitdiffstats
path: root/collection/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-02-01 10:33:28 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-02-03 10:35:17 -0500
commit3d26bc84a31d559704d1c33673bde066a5861fae (patch)
tree89d0a115189b31da7977e6b51c17845462af1c25 /collection/Makefile.am
parent53ff0724abd2e1f4bac2cb8298b0b4d481da8560 (diff)
downloadding-libs2-3d26bc84a31d559704d1c33673bde066a5861fae.tar.gz
ding-libs2-3d26bc84a31d559704d1c33673bde066a5861fae.tar.xz
ding-libs2-3d26bc84a31d559704d1c33673bde066a5861fae.zip
Split off libcollection into a shared library
Diffstat (limited to 'collection/Makefile.am')
-rw-r--r--collection/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/collection/Makefile.am b/collection/Makefile.am
index bd7186b..2734a71 100644
--- a/collection/Makefile.am
+++ b/collection/Makefile.am
@@ -16,12 +16,16 @@ ACLOCAL_AMFLAGS = -I m4
# Set up the pkg-config file
pkgconfigdir = $(libdir)/pkgconfig
-dist_noinst_DATA = \
- collection.pc \
- m4
+dist_pkgconfig_DATA = collection.pc
+
+dist_include_HEADERS = \
+ collection.h \
+ collection_tools.h
+
+dist_noinst_DATA = m4
# Build library
-noinst_LTLIBRARIES = libcollection.la
+lib_LTLIBRARIES = libcollection.la
libcollection_la_SOURCES = \
collection.c \
collection_tools.c \
@@ -30,12 +34,12 @@ libcollection_la_SOURCES = \
collection_stack.c \
collection_cmp.c \
collection_iter.c \
- collection.h \
- collection_tools.h \
collection_priv.h \
collection_queue.h \
collection_stack.h \
../trace/trace.h
+libcollection_la_LDFLAGS = \
+ -version-info 1:0:0
# Build unit test
check_PROGRAMS = collection_ut collection_stack_ut collection_queue_ut