summaryrefslogtreecommitdiffstats
path: root/collection/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2009-07-01 18:22:19 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-07-02 08:16:35 -0400
commit0a74051300097be0bbb69f0a6712a07160f200ee (patch)
treeda60d46a80a283027de1a17fa20b499709282e63 /collection/Makefile.am
parente0278b7d5e5a34827b8b1ef6bc1b15ceee889204 (diff)
downloadding-libs2-0a74051300097be0bbb69f0a6712a07160f200ee.tar.gz
ding-libs2-0a74051300097be0bbb69f0a6712a07160f200ee.tar.xz
ding-libs2-0a74051300097be0bbb69f0a6712a07160f200ee.zip
Queue and stack APIs using collection.
Patch adds two interfaces for stack and queue using collection as underlaying implementation. It also fixes a bug in the insterion code - the unsigned properties were created as long.
Diffstat (limited to 'collection/Makefile.am')
-rw-r--r--collection/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/collection/Makefile.am b/collection/Makefile.am
index 8df9fc6..fe07490 100644
--- a/collection/Makefile.am
+++ b/collection/Makefile.am
@@ -15,12 +15,20 @@ libcollection_la_SOURCES = \
collection.c \
collection_tools.c \
collection_cnv.c \
+ collection_queue.c \
+ collection_stack.c \
collection.h \
collection_tools.h \
collection_priv.h \
+ collection_queue.h \
+ collection_stack.h \
../trace/trace.h
# Build unit test
-noinst_PROGRAMS = collection_ut
+noinst_PROGRAMS = collection_ut collection_stack_ut collection_queue_ut
collection_ut_SOURCES = collection_ut.c
collection_ut_LDADD = libcollection.la
+collection_stack_ut_SOURCES = collection_stack_ut.c
+collection_stack_ut_LDADD = libcollection.la
+collection_queue_ut_SOURCES = collection_queue_ut.c
+collection_queue_ut_LDADD = libcollection.la