summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-05-12 11:56:27 -0400
committerSimo Sorce <ssorce@redhat.com>2009-05-14 11:34:04 -0400
commitcd42b4bd1c519d70aa2c73e5e79290bb40c30e4f (patch)
tree2f13ceddcaea57825113f33e36c1ad945318eb18 /Makefile.am
parente54ce04c11c4a6ff8b5c7bbbd738f70e3da4e101 (diff)
downloadding-libs2-cd42b4bd1c519d70aa2c73e5e79290bb40c30e4f.tar.gz
ding-libs2-cd42b4bd1c519d70aa2c73e5e79290bb40c30e4f.tar.xz
ding-libs2-cd42b4bd1c519d70aa2c73e5e79290bb40c30e4f.zip
Enable building a single libsssd_utils.so from common
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 276bbb2..47d7c4a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,2 +1,19 @@
-SUBDIRS = collection ini trace dhash
ACLOCAL_AMFLAGS = -I m4
+
+if SINGLELIB
+# Build all components as a single shared library
+lib_LTLIBRARIES = libsssd_util.la
+libsssd_util_la_SOURCES = \
+ collection/collection.c \
+ collection/collection_tools.c \
+ ini/ini_config.c \
+ dhash/dhash.c
+libsssd_util_la_CFLAGS = $(AM_CFLAGS) \
+ -I ./collection \
+ -I ./ini \
+ -I ./dhash \
+ -I ./trace
+else
+SUBDIRS = collection ini trace dhash
+endif
+