summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-05-21 09:03:01 -0400
committerSimo Sorce <ssorce@redhat.com>2009-05-26 09:10:45 -0400
commita2111416b0d8ae0a2c1b3090fe62353e2c231ea6 (patch)
tree4636cb48efc877f636b86c901191920885fc2595 /Makefile.am
parent048a614802f36d8173aec5d3fd893ec845460564 (diff)
downloadding-libs2-a2111416b0d8ae0a2c1b3090fe62353e2c231ea6.tar.gz
ding-libs2-a2111416b0d8ae0a2c1b3090fe62353e2c231ea6.tar.xz
ding-libs2-a2111416b0d8ae0a2c1b3090fe62353e2c231ea6.zip
Clean up automake build to work on older versions of libtool
LT_INIT is supported only on Libtool >= 2.0, so I reverted it to using AC_PROG_LIBTOOL. Also reorganized how the common libraries were being built. Now they are treated as libtool convenience libraries instead of installable libraries (the --with-singlelib configure flag can still be used to generate a combined, installable DSO) I cleaned up the set of files being installed by automake, so the list of things we need to remove before packaging the RPM is now only the .la files associated with our own plugins.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 47d7c4a..42bd483 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,19 +1,17 @@
ACLOCAL_AMFLAGS = -I m4
-
+SUBDIRS = trace collection ini dhash
if SINGLELIB
# Build all components as a single shared library
lib_LTLIBRARIES = libsssd_util.la
-libsssd_util_la_SOURCES = \
- collection/collection.c \
- collection/collection_tools.c \
- ini/ini_config.c \
- dhash/dhash.c
+libsssd_util_la_SOURCES =
+libsssd_util_la_LIBADD = \
+ collection/libcollection.la \
+ ini/libini_config.la \
+ dhash/libdhash.la
libsssd_util_la_CFLAGS = $(AM_CFLAGS) \
-I ./collection \
-I ./ini \
-I ./dhash \
-I ./trace
-else
-SUBDIRS = collection ini trace dhash
endif