summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-08-10 11:49:01 -0400
committerStephen Gallagher <sgallagh@redhat.com>2010-08-10 12:24:12 -0400
commit7e7874fdc13902071814897d9a3b2857101db78e (patch)
tree4be08d7136ffe03302ff5233d02439b5c74fa2be /Makefile.am
parentdb4132d61c290116cd74fcc4d32b5a7f25676be5 (diff)
downloadding-libs2-7e7874fdc13902071814897d9a3b2857101db78e.tar.gz
ding-libs2-7e7874fdc13902071814897d9a3b2857101db78e.tar.xz
ding-libs2-7e7874fdc13902071814897d9a3b2857101db78e.zip
Remove toplevel Makefile
All libraries should be built individually now.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 0 insertions, 33 deletions
diff --git a/Makefile.am b/Makefile.am
deleted file mode 100644
index 187ad5e..0000000
--- a/Makefile.am
+++ /dev/null
@@ -1,33 +0,0 @@
-ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = trace dhash path_utils refarray collection ini
-DOCDIRS = path_utils refarray collection ini
-
-dist_noinst_DATA = \
- m4
-
-if SINGLELIB
-# Build all components as a single shared library
-lib_LTLIBRARIES = libsssd_util.la
-libsssd_util_la_SOURCES =
-libsssd_util_la_LIBADD = \
- collection/libcollection.la \
- ini/libini_config.la \
- dhash/libdhash.la \
- refarray/libref_array.la
-libsssd_util_la_CFLAGS = $(AM_CFLAGS) \
- -I ./collection \
- -I ./ini \
- -I ./dhash \
- -I ./refarray \
- -I ./trace
-endif
-
-tests: all
- for subdir in $(SUBDIRS); do \
- $(MAKE) -C $$subdir $@; \
- done
-
-docs:
- for subdir in $(DOCDIRS); do \
- $(MAKE) -C $$subdir $@; \
- done