summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Dennis <jdennis@redhat.com>2009-04-16 17:48:13 -0400
committerSimo Sorce <ssorce@redhat.com>2009-04-22 04:42:43 -0400
commit5d237157deefb39db63acdd950bd67c7809415f6 (patch)
treea571ec93c80b4abd8c190005735cfb9ec2b521cc /Makefile.am
parent7b5f297ac811213629789924cf7f69e520185e98 (diff)
downloadding-libs2-5d237157deefb39db63acdd950bd67c7809415f6.tar.gz
ding-libs2-5d237157deefb39db63acdd950bd67c7809415f6.tar.xz
ding-libs2-5d237157deefb39db63acdd950bd67c7809415f6.zip
add dynamic hash table data structure implementation
Apply suggested fixes by Simo after code review * return statements no longer use () unless it's an expression * remove all use of assert() in library * use bool,true,false instead of int,TRUE,FALSE * add check for NULL hash table in public entry points * example code in header file now a seperate file * assure consistent use of unsigned long data type * add more debugging support * break out generation of integer key into convert_key() function * table parameters now tunable rather than hardcoded * table can now accept custom alloc()/free() functions * add function create_table_ex() to pass extra table parameters * remove MUL(), DIV(), MOD() macros * hash statistics now separate struct which can be queried * test program now accepts tuning parameters, iteration count; has better error checking and reporting fix min/max load factor comman line args in test program
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ea23cb9..94ccd27 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1 +1 @@
-SUBDIRS = collection ini trace
+SUBDIRS = collection ini trace dhash