summaryrefslogtreecommitdiffstats
path: root/path_utils/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-01-22 14:07:51 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-02-03 10:35:16 -0500
commit969886accce03a24b906731643303113b2404e1c (patch)
tree4d31662ed4470691ed73b5e81b54cb20de7e629b /path_utils/Makefile.am
parent1e6a68ff11e21d0ff780277d6fd112da300e041d (diff)
downloadding-libs-969886accce03a24b906731643303113b2404e1c.tar.gz
ding-libs-969886accce03a24b906731643303113b2404e1c.tar.xz
ding-libs-969886accce03a24b906731643303113b2404e1c.zip
Split off libpath_utils into a shared library
Diffstat (limited to 'path_utils/Makefile.am')
-rw-r--r--path_utils/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/path_utils/Makefile.am b/path_utils/Makefile.am
index b738c3e..8539ffd 100644
--- a/path_utils/Makefile.am
+++ b/path_utils/Makefile.am
@@ -8,13 +8,15 @@ endif
ACLOCAL_AMFLAGS = -I m4
pkgconfigdir = $(libdir)/pkgconfig
-dist_noinst_DATA = \
- path_utils.pc \
- m4
+dist_pkgconfig_DATA = path_utils.pc
-noinst_LTLIBRARIES = libpath_utils.la
-libpath_utils_la_SOURCES = \
- path_utils.c \
- path_utils.h
+dist_include_HEADERS = path_utils.h
+
+dist_noinst_DATA = m4
+
+lib_LTLIBRARIES = libpath_utils.la
+libpath_utils_la_SOURCES = path_utils.c
+libpath_utils_la_LDFLAGS = \
+ -version-info 1:0:0
tests: all $(check_PROGRAMS)