summaryrefslogtreecommitdiffstats
path: root/path_utils/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-09-21 14:33:25 -0400
committerStephen Gallagher <sgallagh@redhat.com>2010-09-22 14:48:28 -0400
commit43f7cfb86f2f405e5cf3f78b4f883cd70fe451e3 (patch)
tree6b5f236c9960863645603ae1321e8c2da2248d27 /path_utils/Makefile.am
parent67c9f9b4a1db45159e710c152deb3d12319bea35 (diff)
downloadding-libs-43f7cfb86f2f405e5cf3f78b4f883cd70fe451e3.tar.gz
ding-libs-43f7cfb86f2f405e5cf3f78b4f883cd70fe451e3.tar.xz
ding-libs-43f7cfb86f2f405e5cf3f78b4f883cd70fe451e3.zip
Build all of the ding-libs from the rootding_libs-0_1_0
This changes our approach from having independent tarballs to having a single, monolithic tarball for all of the libraries
Diffstat (limited to 'path_utils/Makefile.am')
-rw-r--r--path_utils/Makefile.am75
1 files changed, 0 insertions, 75 deletions
diff --git a/path_utils/Makefile.am b/path_utils/Makefile.am
deleted file mode 100644
index d83d4b7..0000000
--- a/path_utils/Makefile.am
+++ /dev/null
@@ -1,75 +0,0 @@
-AM_CFLAGS =
-if HAVE_GCC
- AM_CFLAGS += \
- -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
- -Wcast-align -Wwrite-strings
-endif
-
-ACLOCAL_AMFLAGS = -I m4
-
-DOXYGEN = @DOXYGEN@
-
-pkgconfigdir = $(libdir)/pkgconfig
-dist_pkgconfig_DATA = path_utils.pc
-
-dist_include_HEADERS = path_utils.h
-
-dist_noinst_DATA = m4 contrib/libpath_utils.spec.in
-
-lib_LTLIBRARIES = libpath_utils.la
-libpath_utils_la_SOURCES = path_utils.c
-libpath_utils_la_LDFLAGS = \
- -version-info 1:0:0
-
-if HAVE_CHECK
- check_PROGRAMS = path_utils_ut
-endif
-
-path_utils_ut_SOURCES = \
- path_utils_ut.c
-path_utils_ut_CFLAGS = \
- $(AM_CFLAGS) \
- $(CHECK_CFLAGS)
-path_utils_ut_LDADD = \
- $(CHECK_LIBS) \
- libpath_utils.la
-TESTS = $(check_PROGRAMS)
-
-tests: all $(check_PROGRAMS)
-
-if HAVE_DOXYGEN
-docs:
- rm -fR doc
- mkdir -p doc
- $(DOXYGEN) path_utils.cfg.doxy
-else
-docs:
- @echo "Doxygen not installed, cannot generate documentation"
- @exit 1
-endif
-
-builddir ?= .
-RPMBUILD ?= $(PWD)/rpmbuild
-
-rpmroot:
- mkdir -p $(RPMBUILD)/BUILD
- mkdir -p $(RPMBUILD)/RPMS
- mkdir -p $(RPMBUILD)/SOURCES
- mkdir -p $(RPMBUILD)/SPECS
- mkdir -p $(RPMBUILD)/SRPMS
-
-rpms: dist-gzip rpmroot
- cp $(builddir)/contrib/libpath_utils.spec $(RPMBUILD)/SPECS
- cp $(distdir).tar.gz $(RPMBUILD)/SOURCES
- cd $(RPMBUILD); \
- rpmbuild --define "_topdir $(RPMBUILD)" -ba SPECS/libpath_utils.spec
-
-# make srpms will use the old digest algorithm to be compatible
-# with RHEL5
-srpm: dist-gzip rpmroot
- cp $(builddir)/contrib/libpath_utils.spec $(RPMBUILD)/SPECS
- cp $(distdir).tar.gz $(RPMBUILD)/SOURCES
- cd $(RPMBUILD); \
- rpmbuild --define "_topdir $(RPMBUILD)" \
- --define _source_filedigest_algorithm=1 \
- -bs SPECS/libpath_utils.spec