summaryrefslogtreecommitdiffstats
path: root/dhash/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-01-07 15:11:07 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-01-20 08:56:00 -0500
commita799f03edc51320e3a70dfbfe2039d56f3cda260 (patch)
treefa1cb2f6dfda58119836daf40fc92e4cd12dca1e /dhash/Makefile.am
parent60413faaa5c846f30e481de48d5d12f272725943 (diff)
downloadding-libs-a799f03edc51320e3a70dfbfe2039d56f3cda260.tar.gz
ding-libs-a799f03edc51320e3a70dfbfe2039d56f3cda260.tar.xz
ding-libs-a799f03edc51320e3a70dfbfe2039d56f3cda260.zip
Split off libdhash into a shared library
Right now, the pkg-config checks for the system version of libdhash are forcibly disabled, requiring the SSSD to build it from its own tree. In the future, when we split the libraries off from the SSSD, it will be easy to switch this check to the external library.
Diffstat (limited to 'dhash/Makefile.am')
-rw-r--r--dhash/Makefile.am22
1 files changed, 14 insertions, 8 deletions
diff --git a/dhash/Makefile.am b/dhash/Makefile.am
index de3c34d..d5a5618 100644
--- a/dhash/Makefile.am
+++ b/dhash/Makefile.am
@@ -8,22 +8,28 @@ endif
ACLOCAL_AMFLAGS = -I m4
pkgconfigdir = $(libdir)/pkgconfig
-dist_noinst_DATA = \
- dhash.pc \
- m4
+dist_pkgconfig_DATA = dhash.pc
-noinst_LTLIBRARIES = libdhash.la
-libdhash_la_SOURCES = \
- dhash.c \
- dhash.h
+dist_noinst_DATA = m4
+
+dist_include_HEADERS = dhash.h
+
+lib_LTLIBRARIES = libdhash.la
+libdhash_la_SOURCES = dhash.c
+libdhash_la_LDFLAGS = \
+ -version-info 1:0:0
check_PROGRAMS = dhash_test dhash_example
TESTS = $(check_PROGRAMS)
+dhash_test_SOURCES = examples/dhash_test.c
dhash_test_LDADD = dhash.o
+
+dhash_example_SOURCES = examples/dhash_example.c
dhash_example_LDADD = dhash.o
examplesdir = $(docdir)/examples
-dist_noinst_DATA += dhash_test.c dhash_example.c
+dist_examples_DATA = examples/dhash_test.c examples/dhash_example.c
+dist_doc_DATA = README
tests: all $(check_PROGRAMS)