summaryrefslogtreecommitdiffstats
path: root/qarsh.spec
diff options
context:
space:
mode:
authorNathan Straz <nstraz@redhat.com>2010-08-20 11:53:57 -0400
committerNathan Straz <nstraz@redhat.com>2010-08-20 13:43:39 -0400
commit5185a40807f9771031da505f5d86376a407b720f (patch)
tree48c42346b8ec3d3edb7aee2401a6a02e20dbd36d /qarsh.spec
parent2e93454ea38cde6836fe57d2dfd344d4899985d8 (diff)
downloadqarsh-5185a40807f9771031da505f5d86376a407b720f.tar.gz
qarsh-5185a40807f9771031da505f5d86376a407b720f.tar.xz
qarsh-5185a40807f9771031da505f5d86376a407b720f.zip
Don't build selinux-policy during build
The policy is dynamic so should be built on the system after install since we can't guarantee that the build chroot includes the latest selinux-policy package.
Diffstat (limited to 'qarsh.spec')
-rw-r--r--qarsh.spec7
1 files changed, 3 insertions, 4 deletions
diff --git a/qarsh.spec b/qarsh.spec
index 87de56a..91327e1 100644
--- a/qarsh.spec
+++ b/qarsh.spec
@@ -50,15 +50,13 @@ SELinux policy maker for qarsh
%build
make %{?_smp_mflags}
-make -C SELinux
%install
rm -rf $RPM_BUILD_ROOT
make install INSTROOT=$RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{_datadir}/selinux/packages/qarsh
-cp -p SELinux/qarshd.pp $RPM_BUILD_ROOT%{_datadir}/selinux/packages/qarsh
-make -C SELinux clean
+touch $RPM_BUILD_ROOT%{_datadir}/selinux/packages/qarsh/qarshd.pp
%clean
rm -rf $RPM_BUILD_ROOT
@@ -72,7 +70,8 @@ if [ $1 = 0 ]; then
fi
%post selinux
-/usr/sbin/semodule -i %{_datadir}/selinux/packages/qarsh/qarshd.pp || :
+make -C %{_docdir} && make -C %{_docdir} load
+# /usr/sbin/semodule -i %{_datadir}/selinux/packages/qarsh/qarshd.pp || :
/sbin/fixfiles -R qarsh-server restore || :
%postun selinux