summaryrefslogtreecommitdiffstats
path: root/python-zope-cachedescriptors.spec
diff options
context:
space:
mode:
authorNathaniel McCallum <nathaniel@natemccallum.com>2010-06-19 23:42:41 -0400
committerNathaniel McCallum <nathaniel@natemccallum.com>2010-06-19 23:42:41 -0400
commitbc36c28e2a7b2500ea50c6762461a914205f735b (patch)
treea030c25cfca97e47b3cbacdf43011973391eaea0 /python-zope-cachedescriptors.spec
parent7c0107136e7834a1cd237d1a6e92d3bfcf2b13aa (diff)
downloadzenoss-bc36c28e2a7b2500ea50c6762461a914205f735b.tar.gz
zenoss-bc36c28e2a7b2500ea50c6762461a914205f735b.tar.xz
zenoss-bc36c28e2a7b2500ea50c6762461a914205f735b.zip
added python-zope-cachedescriptors.spec
Diffstat (limited to 'python-zope-cachedescriptors.spec')
-rw-r--r--python-zope-cachedescriptors.spec53
1 files changed, 53 insertions, 0 deletions
diff --git a/python-zope-cachedescriptors.spec b/python-zope-cachedescriptors.spec
new file mode 100644
index 0000000..a8411da
--- /dev/null
+++ b/python-zope-cachedescriptors.spec
@@ -0,0 +1,53 @@
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+
+%global modname zope.cachedescriptors
+%global version 3.5.1
+%global release 1
+
+Name: python-zope-cachedescriptors
+Version: %{version}
+Release: %{release}%{?dist}
+Summary: Method and property caching decorators
+
+Group: Development/Libraries
+License: Zope Public License
+URL: http://pypi.python.org/pypi/%{modname}
+Source0: http://pypi.python.org/packages/source/z/%{modname}/%{modname}-%{version}.zip
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+
+BuildRequires: python-devel
+BuildRequires: python-setuptools
+
+%description
+Cached descriptors cache their output. They take into account instance
+attributes that they depend on, so when the instance attributes change, the
+descriptors will change the values they return.
+
+Cached descriptors cache their data in _v_ attributes, so they are also useful
+for managing the computation of volatile attributes for persistent objects.
+
+%prep
+%setup -q -n %{modname}-%{version}
+rm -rf src/%{modname}.egg-info
+
+%build
+%{__python} setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc CHANGES.txt README.txt
+%{python_sitelib}/zope/cachedescriptors
+%{python_sitelib}/%{modname}-%{version}-*.egg-info
+%{python_sitelib}/%{modname}-%{version}-*.pth
+
+%changelog
+* Sat Jun 19 2010 Nathaniel McCallum <nathaniel@natemccallum.com> - 3.5.1-1
+- Initial package