summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c859491..dce40db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,14 @@ AC_SUBST([RDM_SUBDIR])
AC_MSG_CHECKING([install subdirectory name])
AC_MSG_RESULT([$RDM_SUBDIR])
+# Use libtool for compiling and linking, but only with static
+# libraries so far. Dynamic libraries need some more thoughts about
+# sonames, and a strategy for maintaining and breaking API and ABI
+# compatibility, and managing C++ ABI issues.
+LT_INIT([disable-shared])
+LT_LANG([C])
+LT_LANG([C++])
+
# Checks for programs.
AC_PROG_CXX
AC_PROG_AWK
@@ -327,8 +335,6 @@ AS_IF([test "x$RMANDEBUG" != x],
AM_CFLAGS+=" -O2"
AM_CXXFLAGS+=" -O2"
])
-AM_CXXFLAGS+=" -fPIC"
-AM_CFLAGS+=" -fPIC"
AC_DEFINE_UNQUOTED([RMANVERSION], [$RMANVERSION])
AC_DEFINE_UNQUOTED([BASEDBSTRING], ["$BASEDBSTRING"])
AC_DEFINE([EARLY_TEMPLATE])