summaryrefslogtreecommitdiffstats
path: root/rnprotocol/Makefile.am
diff options
context:
space:
mode:
authorConstantin Jucovschi <cj@ubuntu.localdomain>2009-04-24 07:20:22 -0400
committerConstantin Jucovschi <cj@ubuntu.localdomain>2009-04-24 07:20:22 -0400
commit8f27e65bddd7d4b8515ce620fb485fdd78fcdf89 (patch)
treebd328a4dd4f92d32202241b5e3a7f36177792c5f /rnprotocol/Makefile.am
downloadrasdaman-upstream-8f27e65bddd7d4b8515ce620fb485fdd78fcdf89.tar.gz
rasdaman-upstream-8f27e65bddd7d4b8515ce620fb485fdd78fcdf89.tar.xz
rasdaman-upstream-8f27e65bddd7d4b8515ce620fb485fdd78fcdf89.zip
Initial commitv8.0
Diffstat (limited to 'rnprotocol/Makefile.am')
-rw-r--r--rnprotocol/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/rnprotocol/Makefile.am b/rnprotocol/Makefile.am
new file mode 100644
index 0000000..d6a021d
--- /dev/null
+++ b/rnprotocol/Makefile.am
@@ -0,0 +1,47 @@
+#
+# This file is part of rasdaman community.
+#
+# Rasdaman community is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# Rasdaman community is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with rasdaman community. If not, see <http://www.gnu.org/licenses/>.
+#
+# Copyright 2003, 2004, 2005, 2006, 2007, 2008, 2009 Peter Baumann /
+# rasdaman GmbH.
+#
+# For more information please see <http://www.rasdaman.org>
+# or contact Peter Baumann via <baumann@rasdaman.com>.
+#
+# MAKEFILE FOR:
+# module rnprotocol
+#
+# COMMENTS:
+#
+##################################################################
+
+noinst_LIBRARIES=libservercomm.a libclientcomm.a
+
+libservercomm_a_SOURCES=rnprotocol.cc rnprotocol.hh \
+ rnpembedded.cc rnpembedded.hh \
+ rnpcommunication.cc rnpcommunication.hh \
+ rnpserver.cc rnpserver.hh \
+ srvrasmgrcomm.cc srvrasmgrcomm.hh \
+ rnprasserver.cc rnprasserver.hh \
+ rnpservercomm.cc rnpservercomm.hh
+
+libclientcomm_a_SOURCES=rnprotocol.cc rnprotocol.hh \
+ rnpembedded.cc rnpembedded.hh \
+ rnpcommunication.cc rnpcommunication.hh \
+ rnprasserver.cc \
+ rnpclientcomm.cc rnpclientcomm2.cc rnpclientcomm.hh
+
+CLEANFILES=core
+