summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2008-06-27 02:26:55 +0200
committerHans Ulrich Niedermann <hun@n-dimensional.de>2008-07-15 12:28:54 +0200
commit6f848030dd6de2e5aa6276a79661c807835b8115 (patch)
tree57f48fbfa134986bc78fbff565e34eacc2a98271 /Makefile.am
parentfdec34d744e03361bb177b171359c4e3e5d23f35 (diff)
downloadnbb-6f848030dd6de2e5aa6276a79661c807835b8115.tar.gz
nbb-6f848030dd6de2e5aa6276a79661c807835b8115.tar.xz
nbb-6f848030dd6de2e5aa6276a79661c807835b8115.zip
Check for tool presence (git, rsync, etc. pp)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c1e1f40..98cfae7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,7 +45,7 @@ if HAVE_NDIM_MAN2TXT
endif
# Requires git 1.5 to work properly.
-GIT = git
+if HAVE_GIT
tag:
test -d "$(top_srcdir)/.git"
@cd "$(top_srcdir)" && $(GIT) status;:
@@ -76,7 +76,9 @@ tag:
msgfile="$$PWD/TAG-MESSAGE"; \
cd "$(top_srcdir)" && $(GIT) tag -s -F "$$msgfile" "v$(TAG)"; \
rm -f "$$msgfile"
+endif
+if HAVE_RSYNC
UPLOAD_DIR = upload-dir
ALL_UPLOAD_FILES = $(UPLOAD_FILES) $(distdir).tar.bz2
upload: $(UPLOAD_FILES) dist
@@ -88,6 +90,7 @@ upload: $(UPLOAD_FILES) dist
rsync -avz --delete "$(UPLOAD_DIR)/" $(RSYNC_HOST):$(RSYNC_DIR)/$(PACKAGE_TARNAME)/
rm -rf "$(UPLOAD_DIR)"
if test -d "$(top_srcdir)/.git"; then cd "$(top_srcdir)" && git push public master; fi
+endif
clean-local:
rm -rf "$(UPLOAD_DIR)"