summaryrefslogtreecommitdiffstats
path: root/mingw32-libltdl.spec
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2009-02-02 13:00:27 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2009-02-02 13:00:27 +0100
commit1e32e374904d8fff0497e2c6d6ef9155ad601ec4 (patch)
treefd17d344101ab692e016ac80eac85d5a2fdf4531 /mingw32-libltdl.spec
parentaf57ba4bfd9a003630a28fa7539db2cab40a1619 (diff)
downloadmingw32-libltdl-package-1e32e374904d8fff0497e2c6d6ef9155ad601ec4.tar.gz
mingw32-libltdl-package-1e32e374904d8fff0497e2c6d6ef9155ad601ec4.tar.xz
mingw32-libltdl-package-1e32e374904d8fff0497e2c6d6ef9155ad601ec4.zip
First go at having package build OK
Diffstat (limited to 'mingw32-libltdl.spec')
-rw-r--r--mingw32-libltdl.spec104
1 files changed, 26 insertions, 78 deletions
diff --git a/mingw32-libltdl.spec b/mingw32-libltdl.spec
index f83a84e..70f806b 100644
--- a/mingw32-libltdl.spec
+++ b/mingw32-libltdl.spec
@@ -6,97 +6,64 @@
%define gcc_version 4.3.2
-Summary: FIXME The GNU Portable Library Tool
-Name: mingw32-libtool
-Version: 1.5.26
-Release: 5%{?dist}
-License: GPLv2+ and LGPLv2+ and GFDL
-Group: Development/Tools
+Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
+Name: mingw32-libltdl
+Version: 1.5.26
+Release: 5%{?dist}
+Group: System Environment/Libraries
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+License: GPLv2+ and LGPLv2+ and GFDL
+Group: Development/Tools
+
Source: http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.gz
URL: http://www.gnu.org/software/libtool/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
-Requires(post): /sbin/install-info
-Requires(preun): /sbin/install-info
-Patch1: libtool-1.5.24-multilib.patch
# don't read .la file in current working directory, root might get tricked
# into running a prepared binary in that directory:
Patch2: libtool-1.5.24-relativepath.patch
-BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo
-Requires: autoconf >= 2.58, automake >= 1.4
-
BuildRequires: mingw32-filesystem >= 30
BuildRequires: mingw32-binutils
# make sure we can configure all supported langs
BuildRequires: mingw32-gcc
BuildRequires: mingw32-gcc-c++
-# /usr/bin/libtool includes paths within gcc's versioned directories
-# Libtool must be rebuilt whenever a new upstream gcc is built
-Requires: mingw32-gcc = %{gcc_version}
%description
-GNU Libtool is a set of shell scripts which automatically configure UNIX and
-UNIX-like systems to generically build shared libraries. Libtool provides a
-consistent, portable interface which simplifies the process of using shared
-libraries.
-
-If you are developing programs which will use shared libraries, but do not use
-the rest of the GNU Autotools (such as GNU Autoconf and GNU Automake), you
-should install the libtool package.
-
-The libtool package also includes all files needed to integrate the GNU
-Portable Library Tool (libtool) and the GNU Libtool Dynamic Module Loader
-(ltdl) into a package built using the GNU Autotools (including GNU Autoconf
-and GNU Automake).
-
-This package includes a modification from the original GNU Libtool to allow
-support for multi-architecture systems, such as the AMD64 Opteron and the Intel
-64-bit Xeon.
-
-
-
-%package ltdl
-Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
-Group: System Environment/Libraries
-Provides: libtool-libs = %{version}-%{release}
-Obsoletes: libtool-libs < 1.5.20
-License: LGPLv2+
-Requires(post): /sbin/ldconfig
-Requires(postun): /sbin/ldconfig
-
-%description ltdl
-The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
+The mingw32-libltdl package contains the GNU Libtool Dynamic Module Loader, a
library that provides a consistent, portable interface which simplifies the
-process of using dynamic modules.
+process of using dynamic modules, for the mingw32 cross compilation
+environment.
These runtime libraries are needed by programs that link directly to the
-system-installed ltdl libraries; they are not needed by software built using the
-rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
+system-installed ltdl libraries; they are not needed by software built using
+the rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
-%package ltdl-devel
+%package devel
Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
Group: Development/Libraries
Requires: libtool-ltdl = %{version}-%{release}
License: LGPLv2+
-%description ltdl-devel
+%description devel
Static libraries and header files for development with ltdl.
%prep
%setup -n libtool-%{version} -q
-%patch1 -p1
+#patch1 -p1
%patch2 -p1
%build
export PATH=%{_mingw32_bindir}:$PATH
-./bootstrap
+#./bootstrap
+cd libltdl
export CC=i686-pc-mingw32-gcc
export CXX=gi686-pc-mingw32-g++
export F77=false
@@ -114,6 +81,7 @@ make #%{?_smp_mflags}
%install
rm -rf %{buildroot}
+cd libltdl
make install DESTDIR=$RPM_BUILD_ROOT
rm -f %{buildroot}%{_infodir}/dir
@@ -123,39 +91,19 @@ rm -f %{buildroot}%{_infodir}/dir
rm -rf %{buildroot}
+%post -p /sbin/ldconfig
-%post
-/sbin/install-info %{_infodir}/libtool.info.gz %{_infodir}/dir || :
-
-%post ltdl -p /sbin/ldconfig
-
-
-
-%preun
-if [ "$1" = 0 ]; then
- /sbin/install-info --delete %{_infodir}/libtool.info.gz %{_infodir}/dir || :
-fi
-
-%postun ltdl -p /sbin/ldconfig
-
+%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
-%doc AUTHORS COPYING NEWS README THANKS TODO ChangeLog
-%{_mingw32_infodir}/libtool.info
-%{_mingw32_bindir}/libtool
-%{_mingw32_bindir}/libtoolize
-%{_mingw32_datadir}/aclocal/*.m4
-%{_mingw32_datadir}/libtool
-
-%files ltdl
-%defattr(-,root,root)
+%doc AUTHORS NEWS THANKS TODO ChangeLog
%doc libltdl/COPYING.LIB libltdl/README
%{_mingw32_libdir}/libltdl.dll.a
%{_mingw32_bindir}/libltdl-3.dll
-%files ltdl-devel
+%files devel
%defattr(-,root,root)
%{_mingw32_libdir}/libltdl.a
%{_mingw32_libdir}/libltdl.la
@@ -164,7 +112,7 @@ fi
%changelog
* Sun Feb 1 2009 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.5.26-5
-- migrate to mingw32 standards
+- Convert native libtool.spec to mingw32-libltdl.spec
* Fri Aug 29 2008 Dennis Gilmore <dennis@ausil.us> 1.5.26-4
- rebuild for gcc-4.3.2