summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 366a0bf..87f3af1 100644
--- a/configure.in
+++ b/configure.in
@@ -1,13 +1,18 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(e2tools.c)
-AM_INIT_AUTOMAKE(e2tools, 0.0.16)
+AC_PREREQ(2.59)
+AC_INIT([e2tools], [0.0.16.1], [hun@n-dimensional.de], [e2tools])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_HEADER([config.h])
+AC_CONFIG_SRCDIR([e2tools.c])
+AC_CONFIG_MACRO_DIR([m4])
+AM_INIT_AUTOMAKE([-Wall -Werror 1.9.6 dist-bzip2])
dnl Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
-AM_MAINTAINER_MODE
+AC_PROG_CC_C_O
dnl Checks for libraries.
@@ -20,6 +25,8 @@ dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_TYPE_MODE_T
AC_TYPE_OFF_T
+AC_TYPE_UINT16_T
+AC_TYPE_UINT64_T
AC_HEADER_TIME
AC_STRUCT_TM
@@ -28,4 +35,5 @@ AC_FUNC_ALLOCA
AC_FUNC_UTIME_NULL
AC_CHECK_FUNCS(gettimeofday regcomp strdup strtol)
-AC_OUTPUT(Makefile)
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT