summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authornalin <nalin>2002-11-18 22:05:08 +0000
committernalin <nalin>2002-11-18 22:05:08 +0000
commitdbf919855d755917146a86ab4e3201041ade0332 (patch)
tree07af350ac300b38df79a96f11ff80f729644613d /configure.ac
parent4e355429e4b3f16de43ef0ac94eafe0a820b0406 (diff)
downloadnss_directories-dbf919855d755917146a86ab4e3201041ade0332.tar.gz
nss_directories-dbf919855d755917146a86ab4e3201041ade0332.tar.xz
nss_directories-dbf919855d755917146a86ab4e3201041ade0332.zip
* src/files-parse.c, src/glibc-parse.c: add glibc-based parsing internally
* src/passwd.c,src/services.c,src/group.c,src/protocols.c,src/shadow.c: use the new parsing code * src/generic.c (setent): return SUCCESS on successful open, not UNAVAIL * src/Makefile.am: export only _nss_directories_[sge]*, to export the setent, getent/getby, and endent functions, but not the parsers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 0d4bb7f..383940d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,12 +19,6 @@ then
fi
AC_SUBST(moduledir)
-AC_CHECK_LIB(nss_files,_nss_files_parse_pwent)
-AC_CHECK_LIB(nss_files,_nss_files_parse_grent)
-AC_CHECK_LIB(nss_files,_nss_files_parse_spent)
-AC_CHECK_LIB(nss_files,_nss_files_parse_servent)
-AC_CHECK_LIB(nss_files,_nss_files_parse_protoent)
-
nss_files=`ls -1 "$moduledir"/libnss_files-*.so | head -1`
GLIBC_VERSION=`basename "$nss_files" .so | cut -f2 -d-`
AC_SUBST(GLIBC_VERSION)