summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authornalin <nalin>2003-10-23 01:44:42 +0000
committernalin <nalin>2003-10-23 01:44:42 +0000
commite4dd57ea3d4c8c81d11f6e91f5d95452d7618c04 (patch)
tree67b5598296796d6cfb1dc9338775ae527e815e8a /Makefile.am
parent969d4f74b472f70b05b3abaa20347bb592d5462e (diff)
downloadnss_directories-e4dd57ea3d4c8c81d11f6e91f5d95452d7618c04.tar.gz
nss_directories-e4dd57ea3d4c8c81d11f6e91f5d95452d7618c04.tar.xz
nss_directories-e4dd57ea3d4c8c81d11f6e91f5d95452d7618c04.zip
- Stop referencing previously-freed memory, doh.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 65d89e7..378cd15 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,8 @@ EXTRA_DIST = ChangeLog COPYING README nss_directories.spec
DISTCHECK_CONFIGURE_FLAGS = --with-moduledir=$$dc_install_base/modules
NAME = nss_directories
-VERSION = $(shell rpm -q --specfile --qf '%{version}' $(top_srcdir)/$(NAME).spec)
+VERSION=@VERSION@
+RELEASE=@RELEASE@
CVSTAG = $(shell echo $(NAME)-$(VERSION) | sed -e s,\\.,_,g -e s,-,_,g)
tag:
@@ -12,9 +13,10 @@ tag:
force-tag:
cvs tag -cF $(CVSTAG)
+distdir = $(NAME)-$(VERSION)-$(RELEASE)
archive:
$(RM) -fr /tmp/$(NAME)-$(VERSION)
- cd /tmp ; cvs -d $(shell cat $(top_srcdir)/CVS/Root) export -r $(CVSTAG) -d $(NAME)-$(VERSION) $(NAME)
+ cd /tmp ; cvs -d $(shell cat $(top_srcdir)/CVS/Root) export -r $(CVSTAG) -d $(NAME)-$(VERSION)-$(RELEASE) $(NAME)
cd /tmp/$(NAME)-$(VERSION) ; ./autogen.sh ; make distcheck
mv -v /tmp/$(NAME)-$(VERSION)/$(NAME)-*.*.tar.* $(top_srcdir)/
$(RM) -fr /tmp/$(NAME)-$(VERSION)