summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin Sivak <msivak@redhat.com>2012-11-26 14:22:37 +0100
committerMartin Sivak <msivak@redhat.com>2012-11-26 14:22:37 +0100
commit7ce2995ee6cab68d1f171b4d050ffb543185def3 (patch)
treee26fd98a77f7ff5c52066984e8d43c63d6213c0c /setup.py
parent402715358322359b43b90a460ea43cce35a0122f (diff)
downloadpython-di-7ce2995ee6cab68d1f171b4d050ffb543185def3.tar.gz
python-di-7ce2995ee6cab68d1f171b4d050ffb543185def3.tar.xz
python-di-7ce2995ee6cab68d1f171b4d050ffb543185def3.zip
SPEC file cleanup and move to nosetests
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 13 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 2f1a99c..4008561 100644
--- a/setup.py
+++ b/setup.py
@@ -15,15 +15,17 @@ setup(
author_email = "msivak@redhat.com",
description = ("Python module which provides decorators to make "
"dependency injection easy to use."),
- license = "GPLv2+",
- keywords = "testing dependency injection IoC",
- url = "http://fedorapeople.org/cgit/msivak/public_git/python-di.git/",
- packages = ['di'],
- long_description=read('README'),
- classifiers=[
- "Development Status :: 3 - Alpha",
- "Intended Audience :: Developers",
- "Topic :: Software Development :: Testing",
- "License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)",
- ],
+ license = "GPLv2+",
+ keywords = "testing dependency injection IoC",
+ url = "http://fedorapeople.org/cgit/msivak/public_git/python-di.git/",
+ packages = ['di'],
+ setup_requires= ['nose>=1.0'],
+ test_suite = "di",
+ long_description=read('README'),
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Intended Audience :: Developers",
+ "Topic :: Software Development :: Testing",
+ "License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)",
+ ],
)