summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 18 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 86ddd4d..91b7312 100644
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,9 @@
#
import os
-from setuptools import setup
+from setuptools import setup, find_packages
+from babel.messages import frontend as babel
+from glob import *
# Utility function to read the README file.
# Used for the long_description. It's nice, because now 1) we have a top level
@@ -30,10 +32,15 @@ from setuptools import setup
def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
-from glob import *
-import os
-data_files = [('/lib/systemd/system', glob('systemd/*.service'))]
+data_files = [('/lib/systemd/system', glob('systemd/*.service')),
+ ('/usr/share/inital-setup/modules', glob('modules/*'))]
+
+# add localization files
+data_files += [('/usr/share/locale/%s/LC_MESSAGES' % dirname,
+ ['locale/%s/LC_MESSAGES/inital-setup.mo' % dirname])
+ for dirname in os.listdir("locale")
+ if not dirname.endswith(".pot")]
# add the firstboot start script for s390 architectures
if os.uname()[4].startswith('s390'):
@@ -49,7 +56,9 @@ setup(
url='http://fedoraproject.org/wiki/FirstBoot',
license = "GPLv2+",
keywords = "firstboot inital setup",
- packages = ['inital_setup'],
+ packages = find_packages(),
+ scripts = ["inital-setup"],
+ data_files = data_files,
setup_requires= ['nose>=1.0'],
test_suite = "inital_setup",
long_description=read('README'),
@@ -59,4 +68,8 @@ setup(
"Topic :: Software Development :: Testing",
"License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)",
],
+ cmdclass = {'compile_catalog': babel.compile_catalog,
+ 'extract_messages': babel.extract_messages,
+ 'init_catalog': babel.init_catalog,
+ 'update_catalog': babel.update_catalog}
)