summaryrefslogtreecommitdiffstats
path: root/firstaidkit.spec
diff options
context:
space:
mode:
authorJoel Andres Granados <jgranado@redhat.com>2008-01-11 13:10:18 +0100
committerJoel Andres Granados <jgranado@redhat.com>2008-01-11 13:10:18 +0100
commit9fe6ef1749cc468cb48418bde27e86f5a9226319 (patch)
treeb5f09b3f4307fba5590567500486a882743961a3 /firstaidkit.spec
parent0ca8e93f08f7e639bb757b2f3691fc7c2932ec96 (diff)
downloadfirstaidkit-9fe6ef1749cc468cb48418bde27e86f5a9226319.tar.gz
firstaidkit-9fe6ef1749cc468cb48418bde27e86f5a9226319.tar.xz
firstaidkit-9fe6ef1749cc468cb48418bde27e86f5a9226319.zip
Specify that the firstaidkit plugin man page is for plugin development.
Organise the packaging. (firstaidkit, firstaidkit-devel and firstaidkit-plugin-all) Comment in spec file on how to create the tar file. Use the reporting code in sample1Plugin.py script make a general way of creating the default config stuff
Diffstat (limited to 'firstaidkit.spec')
-rw-r--r--firstaidkit.spec69
1 files changed, 59 insertions, 10 deletions
diff --git a/firstaidkit.spec b/firstaidkit.spec
index 4c9a6d3..bb0db89 100644
--- a/firstaidkit.spec
+++ b/firstaidkit.spec
@@ -1,8 +1,15 @@
+#
+# Spec file for firstaidkit
+#
+# How to create the tar file:
+# After cloning the git repo, run the folloing line from the directory that contains firstaidkit.
+# VER=`cat firstaidkit/firstaidkit.spec | grep Version | awk 'system(echo )'` ; mv firstaidkit/ firstaidkit-$VER/ ; tar cvfj firstaidkit-$VER.tar.bz2 firstaidkit-$VER --exclude='*.git' --exclude='.placeholder'; mv firstaidkit-$VER/ firstaidkit/
+
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
Name: firstaidkit
Version: 0.1.0
-Release: 3%{?dist}
+Release: 6%{?dist}
Summary: System Rescue Tool
Group: Applications/System
@@ -21,9 +28,32 @@ BuildRequires: python-setuptools
BuildArch: noarch
+
+%package devel
+Group: Applications/System
+Summary: Devel package for firstaidkit
+Requires: %{name} = %{version}-%{release}
+
+%package plugin-all
+Group: Applications/System
+Summary: All firstaidkit plugins
+#
+# Since there are no plugins yet, this section only has firstaidkit as requires.
+#
+Requires: %{name} = %{version}-%{release}
+
+
%description
A tool that automates simple and common system recovery tasks.
+%description devel
+Provides the examples and requires firstaidkit without plugins.
+
+%description plugin-all
+This package provides all the necessary firstaidkit plugins. It
+probes the system and according to what it finds, it installs the
+needed firstaidkit plugins.
+
%prep
%setup -q
@@ -33,28 +63,47 @@ A tool that automates simple and common system recovery tasks.
%install
-rm -rf $RPM_BUILD_ROOT
+%{__rm} -rf $RPM_BUILD_ROOT
%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
-%{__install} -d $RPM_BUILD_ROOT/%{_libexecdir}/firstaidkit/plugins
-%{__install} -d $RPM_BUILD_ROOT/%{_mandir}/man1
-%{__install} doc/fakplugin.1 $RPM_BUILD_ROOT/%{_mandir}/man1
-%{__cp} -rfp plugins/* $RPM_BUILD_ROOT/%{_libexecdir}/firstaidkit/plugins
+%{__install} -d $RPM_BUILD_ROOT%{_mandir}/man1
+%{__install} -p doc/fakplugin.1 doc/firstaidkit.1 $RPM_BUILD_ROOT/%{_mandir}/man1
+%{__install} -d $RPM_BUILD_ROOT%{_libdir}/firstaidkit-plugins/examples
+
+%{__cp} -rfp plugins/* $RPM_BUILD_ROOT%{_libdir}/firstaidkit-plugins/examples
%clean
-rm -rf $RPM_BUILD_ROOT
+%{__rm} -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
-%doc AUTHORS COPYING doc/README doc/PLUGINS
+%doc AUTHORS COPYING doc/README
# For noarch packages: sitelib
%{python_sitelib}/pyfirstaidkit
%{python_sitelib}/%{name}-%{version}-py2.5.egg-info
%{_bindir}/firstaidkit
-%{_libexecdir}/firstaidkit/plugins/*
-%attr(0644,-,-) %{_mandir}/man1/fakplugin.1.gz
+%attr(0644,root,root) %{_mandir}/man1/firstaidkit.1.gz
+
+%files devel
+%{_libdir}/firstaidkit-plugins/examples
+%attr(0644,root,root) %{_mandir}/man1/fakplugin.1.gz
+
+%files plugin-all
%Changelog
+* Wed Jan 09 2008 Joel Granados <jgranado@redhat.com> 0.1.0-6
+- Put examples under the firstaidkit-plugins dir
+- Create a firstaidkit-plugin-all package
+
+* Tue Jan 08 2008 Joel Granados <jgranado@redhat.com> 0.1.0-5
+- Leave just the firstaidkit and firstaidkit-devel pacages.
+
+* Mon Jan 07 2008 Joel Granados <jgranado@redhat.com> 0.1.0-4
+- Create firstaidkit dummy package
+- Create firstaidkit-pluginsystem subpackage
+- Create firstaidkit-devel subpackage
+- Bump the release tag
+
* Fri Jan 04 2008 Joel Granados <jgranado@redhat.com> 0.1.0-3
- Change the License variable
- Fix man page being executable