summaryrefslogtreecommitdiffstats
path: root/pyanaconda/Makefile.am
diff options
context:
space:
mode:
authorMartin Sivak <msivak@redhat.com>2010-05-11 17:31:06 +0200
committerMartin Sivak <msivak@redhat.com>2010-05-31 14:21:49 +0200
commit78421d4ed23ad58b021c4d9d1bae690b99c167fe (patch)
tree909c1b650afe9afea03ecf1a03b2d39d39cf72b7 /pyanaconda/Makefile.am
parent40b979f28cfd73078d5dd58b8f7e97e76198a222 (diff)
downloadanaconda-78421d4ed23ad58b021c4d9d1bae690b99c167fe.tar.gz
anaconda-78421d4ed23ad58b021c4d9d1bae690b99c167fe.tar.xz
anaconda-78421d4ed23ad58b021c4d9d1bae690b99c167fe.zip
Structure the repo layout so it matches final structure better and make isys a real Python package.
Also updates the build and autotools stuff to work with the new structure
Diffstat (limited to 'pyanaconda/Makefile.am')
-rw-r--r--pyanaconda/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/pyanaconda/Makefile.am b/pyanaconda/Makefile.am
new file mode 100644
index 000000000..0b9df7797
--- /dev/null
+++ b/pyanaconda/Makefile.am
@@ -0,0 +1,34 @@
+# liveinst/Makefile.am for anaconda
+#
+# Copyright (C) 2009 Red Hat, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as published
+# by the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+# Author: Martin Sivak <msivak@redhat.com>
+
+SUBDIRS = installclasses iw textw storage
+
+MAINTAINERCLEANFILES = Makefile.in
+
+# anaconda Python code
+pkgpyexecdir = $(pyexecdir)/py$(PACKAGE_NAME)
+anacondadir = $(pkgpyexecdir)
+anaconda_PYTHON = *.py
+pkgpyexec_LTLIBRARIES = xutils.la
+
+xutils_la_CFLAGS = $(PYTHON_INCLUDES) $(GDK_CFLAGS) -fno-strict-aliasing
+xutils_la_LDFLAGS = -module -avoid-version $(PYTHON_LDFLAGS) $(GDK_LDFLAGS)
+xutils_la_LIBADD = $(PYTHON_LIBS) $(GDK_LIBS)
+xutils_la_SOURCES = xutils.c
+