summaryrefslogtreecommitdiffstats
path: root/dracut/Makefile.am
diff options
context:
space:
mode:
authorWill Woods <wwoods@redhat.com>2012-02-15 15:37:31 -0500
committerWill Woods <wwoods@redhat.com>2012-03-16 12:36:55 -0400
commite42db18fda53c97a847ab68a1a1ddf05d4578fab (patch)
tree846e8b1ab27de33d8aeb7764bd0aac9e13203517 /dracut/Makefile.am
parent81956dcfddea203629b51f558beb1104285c2399 (diff)
downloadanaconda-e42db18fda53c97a847ab68a1a1ddf05d4578fab.tar.gz
anaconda-e42db18fda53c97a847ab68a1a1ddf05d4578fab.tar.xz
anaconda-e42db18fda53c97a847ab68a1a1ddf05d4578fab.zip
Add anaconda dracut module [WIP!]
This adds the dracut directory and anaconda-dracut subpackage. The 'anaconda' dracut module replaces loader. It should handle all the tasks that loader used to handle in the first stage of the boot process. It's a work in progress, but it currently supports repo={http,ftp,nfs} and most anacaconda network options. Kickstart parsing is handled using a python interpreter and pykickstart, which (surprisingly) only adds ~600k to the initramfs. Driver disks are not yet supported.
Diffstat (limited to 'dracut/Makefile.am')
-rw-r--r--dracut/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/dracut/Makefile.am b/dracut/Makefile.am
new file mode 100644
index 000000000..152108de8
--- /dev/null
+++ b/dracut/Makefile.am
@@ -0,0 +1,35 @@
+# dracut/Makefile.am for anaconda
+#
+# Copyright (C) 2012 Red Hat, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as published
+# by the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+# Author: Will Woods <wwoods@redhat.com>
+
+dracutdir = $(datadir)/dracut/modules.d/80$(PACKAGE_NAME)
+dist_dracut_DATA = module-setup.sh \
+ pythondeps.sh \
+ anaconda-lib.sh \
+ parse-anaconda-options.sh \
+ parse-anaconda-repo.sh \
+ parse-anaconda-kickstart.sh \
+ repo-genrules.sh \
+ anaconda-nfsroot \
+ anaconda-hdroot \
+ anaconda-copy-ks.sh \
+ fetch-kickstart \
+ parse-kickstart
+
+
+MAINTAINERCLEANFILES = Makefile.in