summaryrefslogtreecommitdiffstats
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2009-06-09 11:19:12 -1000
committerDavid Cantrell <dcantrell@redhat.com>2009-06-09 12:26:51 -1000
commit89f4b061da9670dbb768d718b88f7be403a36c34 (patch)
tree3439d3ec5e20a470cc3108b8a9037e7213a28f00 /docs/Makefile.am
parent56795a36533e6ebce4b62218909304422ef46ba2 (diff)
downloadanaconda-89f4b061da9670dbb768d718b88f7be403a36c34.tar.gz
anaconda-89f4b061da9670dbb768d718b88f7be403a36c34.tar.xz
anaconda-89f4b061da9670dbb768d718b88f7be403a36c34.zip
Convert docs/ to Makefile.am, add gettext.txt
Add gettext.txt, which explains the structure of po/ with the GNU gettext template system.
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
new file mode 100644
index 000000000..14ba2f38e
--- /dev/null
+++ b/docs/Makefile.am
@@ -0,0 +1,32 @@
+# docs/Makefile.am for anaconda
+#
+# Copyright (C) 2009 Red Hat, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as published
+# by the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+# Author: David Cantrell <dcantrell@redhat.com>
+
+EXTRA_DIST = install-methods.txt mediacheck.txt anaconda-release-notes.txt \
+ lvm_sanity_checks.txt rescue-mode api.cfg making-screenshots \
+ threads.txt command-line.txt kickstart-docs.txt gettext.txt
+
+CLEANFILES = api *.xml
+
+MAINTAINERCLEANFILES = Makefile.in command-line.txt kickstart-docs.txt
+
+command-line.txt:
+ curl -A "anaconda-build" -o command-line.txt "http://fedoraproject.org/w/index.php?title=Anaconda_Boot_Options&action=raw"
+
+kickstart-docs.txt:
+ curl -A "anaconda-build" -o kickstart-docs.txt "http://fedoraproject.org/w/index.php?title=Anaconda/Kickstart&action=raw"