summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2010-11-09 11:09:24 -1000
committerDavid Cantrell <dcantrell@redhat.com>2010-11-10 08:49:41 -1000
commitd05c94c86fa71c274130a8f512fbb5c0cd7d6047 (patch)
tree7f460945bddbbfafb38afcef1c5ac806c61f90e3 /configure.ac
parent0c91612c645fc7c99c9a6928b34a437d30280faa (diff)
downloadanaconda-d05c94c86fa71c274130a8f512fbb5c0cd7d6047.tar.gz
anaconda-d05c94c86fa71c274130a8f512fbb5c0cd7d6047.tar.xz
anaconda-d05c94c86fa71c274130a8f512fbb5c0cd7d6047.zip
Do not force -O2 in CFLAGS.
The compiler optimization level will be set by the RPM_OPT_FLAGS at package build time. By not forcing -O2, we can more easily build with -O0 for debugging purposes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 74cb092be..38bfce578 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,7 +143,7 @@ PKG_CHECK_MODULES([LIBARCHIVE], [libarchive >= 2.7.902a])
# Set $RPM_OPT_FLAGS if we don't have it
if test -z $RPM_OPT_FLAGS ; then
- CFLAGS="$CFLAGS -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions"
+ CFLAGS="$CFLAGS -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions"
else
CFLAGS="$CFLAGS $RPM_OPT_FLAGS"
fi