summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Sivak <msivak@redhat.com>2010-05-11 17:31:06 +0200
committerMartin Sivak <msivak@redhat.com>2010-05-31 14:21:49 +0200
commit78421d4ed23ad58b021c4d9d1bae690b99c167fe (patch)
tree909c1b650afe9afea03ecf1a03b2d39d39cf72b7 /Makefile.am
parent40b979f28cfd73078d5dd58b8f7e97e76198a222 (diff)
downloadanaconda-78421d4ed23ad58b021c4d9d1bae690b99c167fe.tar.gz
anaconda-78421d4ed23ad58b021c4d9d1bae690b99c167fe.tar.xz
anaconda-78421d4ed23ad58b021c4d9d1bae690b99c167fe.zip
Structure the repo layout so it matches final structure better and make isys a real Python package.
Also updates the build and autotools stuff to work with the new structure
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 3 insertions, 27 deletions
diff --git a/Makefile.am b/Makefile.am
index 9ceac515b..af2f4ab0a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,45 +19,24 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = isys po loader booty storage textw utils scripts bootdisk \
- installclasses iw command-stubs ui docs pixmaps tests fonts \
- gptsync liveinst icons
+SUBDIRS = isys loader gptsync booty pyanaconda data \
+ tests utils scripts docs po
EXTRA_DIST = config.rpath COPYING \
- lang-table \
anaconda.spec.in
MAINTAINERCLEANFILES = Makefile.in config.guess config.h.in config.sub \
depcomp install-sh ltmain.sh missing ABOUT-NLS \
INSTALL aclocal.m4 configure *.pyc py-compile
-CLEANFILES = *~ lang-names anaconda.spec
+CLEANFILES = *~ anaconda.spec
MOSTLYCLEANDIRS = m4
-pkgpyexecdir = $(pyexecdir)/py$(PACKAGE_NAME)
-
dist_noinst_DATA = $(PACKAGE_NAME).spec
dist_sbin_SCRIPTS = anaconda
-udevdir = /lib/udev/rules.d
-dist_udev_DATA = 70-anaconda.rules
-
-langdir = $(datadir)/$(PACKAGE_NAME)
-lang_DATA = lang-names
-dist_lang_DATA = lang-table
-
-pkgpyexec_LTLIBRARIES = xutils.la
-xutils_la_CFLAGS = $(PYTHON_INCLUDES) $(GDK_CFLAGS) -fno-strict-aliasing
-xutils_la_LDFLAGS = -module -avoid-version $(PYTHON_LDFLAGS) $(GDK_LDFLAGS)
-xutils_la_LIBADD = $(PYTHON_LIBS) $(GDK_LIBS)
-xutils_la_SOURCES = xutils.c
-
-# anaconda Python code
-anacondadir = $(pkgpyexecdir)
-anaconda_PYTHON = *.py
-
ARCHIVE_TAG = $(PACKAGE_NAME)-$(PACKAGE_VERSION)-$(PACKAGE_RELEASE)
sed_verbose = $(sed_verbose_$(V))
@@ -67,9 +46,6 @@ sed_verbose_0 = @echo " SED "$@;
$(PACKAGE_NAME).spec: $(PACKAGE_NAME).spec.in
$(sed_verbose)sed -e 's/#VERSION#/$(PACKAGE_VERSION)/' < $< > $@
-lang-names: lang-table
- PYTHONPATH="." $(PYTHON) scripts/getlangnames.py > lang-names
-
testiso: install
@if [ "$(REPO)" = "" ]; then echo "ERROR: Need a repo to pull packages from!" ; exit 1 ; fi
@pushd scripts ; sudo ./buildinstall --version $(PACKAGE_VERSION) --product $(PACKAGE_NAME) --release $(PACKAGE_NAME)-$(PACKAGE_VERSION) --output $(shell pwd)/outiso --updates $(DESTDIR) $(REPO) ; popd ; cp outiso/images/boot.iso ./boot.iso ; sudo rm -rf outiso