summaryrefslogtreecommitdiffstats
path: root/src/report-python/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <dvlasenk@redhat.com>2010-12-14 17:17:07 +0100
committerDenys Vlasenko <dvlasenk@redhat.com>2010-12-14 17:17:07 +0100
commitb1f4a3256004e8f12c15511d2b77074a3002b9f2 (patch)
treed87ed73b341bafa0831668ed2a7fdb4431cdcb82 /src/report-python/Makefile.am
parent8598b22e101201de4d06ea48f2b500f81f2b30d5 (diff)
downloadabrt-b1f4a3256004e8f12c15511d2b77074a3002b9f2.tar.gz
abrt-b1f4a3256004e8f12c15511d2b77074a3002b9f2.tar.xz
abrt-b1f4a3256004e8f12c15511d2b77074a3002b9f2.zip
jury-rig compile for python2.6; small style fixes
Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Diffstat (limited to 'src/report-python/Makefile.am')
-rw-r--r--src/report-python/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/report-python/Makefile.am b/src/report-python/Makefile.am
index 34ec090c..9c7e86d7 100644
--- a/src/report-python/Makefile.am
+++ b/src/report-python/Makefile.am
@@ -5,7 +5,9 @@ pyreportexec_PYTHON = __init__.py
pyreportexec_LTLIBRARIES = _pyreport.la
_pyreport_la_SOURCES = \
- reportmodule.c crash_dump.c py_crash_dump.h pyreport_common.h
+ reportmodule.c \
+ crash_dump.c py_crash_dump.h \
+ pyreport_common.h
_pyreport_la_CPPFLAGS = \
-I$(srcdir)/../include/report -I$(srcdir)/../include \
-DDEBUG_DUMPS_DIR=\"$(DEBUG_DUMPS_DIR)\" \
@@ -16,7 +18,8 @@ _pyreport_la_CPPFLAGS = \
-DVAR_RUN=\"$(VAR_RUN)\" \
$(GLIB_CFLAGS) \
$(PYTHON_CFLAGS) \
- -D_GNU_SOURCE
+ -D_GNU_SOURCE \
+ -Wall -Werror
_pyreport_la_LDFLAGS = \
-module \
-avoid-version \