summaryrefslogtreecommitdiffstats
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <dvlasenk@redhat.com>2010-11-26 13:21:07 +0100
committerDenys Vlasenko <dvlasenk@redhat.com>2010-11-26 13:21:07 +0100
commit7ca9930ec1fc0aef059a2d8e81f7db6b3c1085ce (patch)
treef08ad3a408d5ae61b8ea6e483016cf45d722a491 /src/plugins/Makefile.am
parent286312ff8017b4d0c0521a3f7c595c85b6f57c52 (diff)
downloadabrt-7ca9930ec1fc0aef059a2d8e81f7db6b3c1085ce.tar.gz
abrt-7ca9930ec1fc0aef059a2d8e81f7db6b3c1085ce.tar.xz
abrt-7ca9930ec1fc0aef059a2d8e81f7db6b3c1085ce.zip
reorganize libraries
This patch does not change any code per se, it renames libABRTfoo -> libabrt_bar and moves a few functions around. After the patch, we are left with the following libs: libabrt - the stuff shared among most of abrt (like xmalloc, logging) libabrt_daemon - only daemon-related things are here (should probably be just moved into daemon - later) libabrt_dbus - daemon, cli and applet use this libabrt_web - abrt-action-foo where foo deals with network/web/ftp/... As a result, we have following reductions in dependent libs: /usr/libexec/abrt-hook-ccpp: linux-vdso.so.1 => () - libABRTUtils.so.0 => /usr/lib64/libABRTUtils.so.0 () + libabrt.so.0 => /usr/lib64/libabrt.so.0 () libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 () - libdbus-1.so.3 => /lib64/libdbus-1.so.3 () - libpthread.so.0 => /lib64/libpthread.so.0 () - librt.so.1 => /lib64/librt.so.1 () - libdl.so.2 => /lib64/libdl.so.2 () /usr/libexec/abrt-action-upload: linux-vdso.so.1 => () libtar.so.1 => /usr/lib64/libtar.so.1 () libcurl.so.4 => /usr/lib64/libcurl.so.4 () - libABRTdUtils.so.0 => /usr/lib64/libABRTdUtils.so.0 () - libABRTUtils.so.0 => /usr/lib64/libABRTUtils.so.0 () + libabrt.so.0 => /usr/lib64/libabrt.so.0 () libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 () - libdbus-1.so.3 => /lib64/libdbus-1.so.3 () Similar savings are in almost every abrt-action-foo. Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am32
1 files changed, 13 insertions, 19 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index c60c06fe..57b99e85 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -90,7 +90,7 @@ abrt_action_analyze_c_CPPFLAGS = \
-D_GNU_SOURCE \
-Wall -Werror
abrt_action_analyze_c_LDADD = \
- ../lib/libABRTUtils.la
+ ../lib/libabrt.la
abrt_action_analyze_python_SOURCES = \
abrt-action-analyze-python.c
@@ -108,7 +108,7 @@ abrt_action_analyze_python_CPPFLAGS = \
-D_GNU_SOURCE \
-Wall -Werror
abrt_action_analyze_python_LDADD = \
- ../lib/libABRTUtils.la
+ ../lib/libabrt.la
abrt_action_analyze_oops_SOURCES = \
abrt-action-analyze-oops.c
@@ -126,7 +126,7 @@ abrt_action_analyze_oops_CPPFLAGS = \
-D_GNU_SOURCE \
-Wall -Werror
abrt_action_analyze_oops_LDADD = \
- ../lib/libABRTUtils.la
+ ../lib/libabrt.la
abrt_action_generate_backtrace_SOURCES = \
abrt-action-generate-backtrace.c
@@ -144,7 +144,7 @@ abrt_action_generate_backtrace_CPPFLAGS = \
-D_GNU_SOURCE \
-Wall -Werror
abrt_action_generate_backtrace_LDADD = \
- ../lib/libABRTUtils.la \
+ ../lib/libabrt.la \
../btparser/libbtparser.la
abrt_action_bugzilla_SOURCES = \
@@ -165,9 +165,8 @@ abrt_action_bugzilla_CPPFLAGS = \
-Wall -Werror
abrt_action_bugzilla_LDADD = \
$(GLIB_LIBS) \
- ../lib/libABRT_web_utils.la \
- ../lib/libABRTdUtils.la \
- ../lib/libABRTUtils.la
+ ../lib/libabrt_web.la \
+ ../lib/libabrt.la
abrt_action_rhtsupport_SOURCES = \
abrt_rh_support.h abrt_rh_support.c \
@@ -191,9 +190,8 @@ abrt_action_rhtsupport_LDFLAGS = -ltar
abrt_action_rhtsupport_LDADD = \
$(GLIB_LIBS) \
$(XMLRPC_LIBS) $(XMLRPC_CLIENT_LIBS) \
- ../lib/libABRT_web_utils.la \
- ../lib/libABRTdUtils.la \
- ../lib/libABRTUtils.la
+ ../lib/libabrt_web.la \
+ ../lib/libabrt.la
abrt_action_upload_SOURCES = \
abrt-action-upload.cpp
@@ -217,8 +215,7 @@ abrt_action_upload_LDFLAGS = -ltar
abrt_action_upload_LDADD = \
$(GLIB_LIBS) \
$(CURL_LIBS) \
- ../lib/libABRTdUtils.la \
- ../lib/libABRTUtils.la
+ ../lib/libabrt.la
abrt_action_kerneloops_SOURCES = \
abrt-action-kerneloops.cpp
@@ -238,9 +235,8 @@ abrt_action_kerneloops_CPPFLAGS = \
-Wall -Werror
# libABRTdUtils is used only because of LoadPluginSettings:
abrt_action_kerneloops_LDADD = \
- ../lib/libABRT_web_utils.la \
- ../lib/libABRTdUtils.la \
- ../lib/libABRTUtils.la
+ ../lib/libabrt_web.la \
+ ../lib/libabrt.la
abrt_action_mailx_SOURCES = \
abrt-action-mailx.cpp
@@ -259,8 +255,7 @@ abrt_action_mailx_CPPFLAGS = \
-D_GNU_SOURCE \
-Wall -Werror
abrt_action_mailx_LDADD = \
- ../lib/libABRTdUtils.la \
- ../lib/libABRTUtils.la
+ ../lib/libabrt.la
abrt_action_print_SOURCES = \
abrt-action-print.cpp
@@ -280,7 +275,6 @@ abrt_action_print_CPPFLAGS = \
-Wall -Werror
# libABRTdUtils is used only because of make_description_logger:
abrt_action_print_LDADD = \
- ../lib/libABRTdUtils.la \
- ../lib/libABRTUtils.la
+ ../lib/libabrt.la
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@