summaryrefslogtreecommitdiffstats
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <dvlasenk@redhat.com>2011-01-06 16:18:09 +0100
committerDenys Vlasenko <dvlasenk@redhat.com>2011-01-06 16:18:09 +0100
commitd108d7d2fbe0b178110295fd8335c258f699a5d4 (patch)
tree3bebcc8c7f66a15383be577beb04300f6fe6e9af /src/lib/Makefile.am
parent6c7086f6c0086496a5a1ae9ab13fdbb310e070ba (diff)
downloadabrt-d108d7d2fbe0b178110295fd8335c258f699a5d4.tar.gz
abrt-d108d7d2fbe0b178110295fd8335c258f699a5d4.tar.xz
abrt-d108d7d2fbe0b178110295fd8335c258f699a5d4.zip
pass old pattern to ccpp hook and use it
abrtd: instead of "|/usr/libexec/abrt-ccpp-hook DEBUG_DUMPS_DIR %p %s %u %c", sets coredump handler to "|/usr/libexec/abrt-ccpp-hook DEBUG_DUMPS_DIR %s %c %p %u %g %t %h %e OLD_PATTERN" abrt-ccpp-hook: expands OLD_PATTERN using values of %s %c %p %u %g %t %h %e and uses it as a name of "compat coredump". Patch has a feature which prevents usage of kernel-truncated OLD_PATTERN: it is passed as hex string *with terminating NUL* (encoded as 00). If ccpp hook doesn't see 00, it refuses to use OLD_PATTERN and uses string "core" instead. Run tested. On a new kernel, passes up to 27 char long old pattern. Longer patterns are still truncated. This may be improved in future kernels. Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index b02acb82..6d6c22bb 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -15,6 +15,7 @@ lib_LTLIBRARIES = \
libreport_la_SOURCES = \
xfuncs.c \
encbase64.c \
+ binhex.c \
stdio_helpers.c \
hash_md5.c hash_md5.h \
hash_sha1.c hash_sha1.h \