summaryrefslogtreecommitdiffstats
path: root/src/gui-wizard-gtk/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <dvlasenk@redhat.com>2011-02-16 15:59:46 +0100
committerDenys Vlasenko <dvlasenk@redhat.com>2011-02-16 15:59:46 +0100
commit3d930bb468cb0613098f417e6f011e366414157c (patch)
treee78377781774e1b897bc9c0c07f9719963c16dd6 /src/gui-wizard-gtk/Makefile.am
parentc2b13d20cd718c3eedf01d40c8f2dc06de3acb21 (diff)
downloadabrt-3d930bb468cb0613098f417e6f011e366414157c.tar.gz
abrt-3d930bb468cb0613098f417e6f011e366414157c.tar.xz
abrt-3d930bb468cb0613098f417e6f011e366414157c.zip
bug-reporting-wizard: store glade file internally
Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Diffstat (limited to 'src/gui-wizard-gtk/Makefile.am')
-rw-r--r--src/gui-wizard-gtk/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/gui-wizard-gtk/Makefile.am b/src/gui-wizard-gtk/Makefile.am
index c199ad01..1c14fa86 100644
--- a/src/gui-wizard-gtk/Makefile.am
+++ b/src/gui-wizard-gtk/Makefile.am
@@ -1,6 +1,7 @@
bin_PROGRAMS = bug-reporting-wizard
bug_reporting_wizard_SOURCES = \
+ wizard_glade.c \
wizard.h wizard.c \
main.c
@@ -30,6 +31,13 @@ bug_reporting_wizard_LDADD = \
-lgmodule-2.0 \
$(GTK_LIBS)
+wizard_glade.c:
+ { \
+ echo '#define WIZARD_GLADE_CONTENTS "\'; \
+ cat $(srcdir)/wizard.glade | sed -e 's/"/\\"/g' -e 's/?/\\?/g' -e 's/$$/\\/g'; \
+ echo '"'; \
+ } >wizard_glade.c
+
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
@INTLTOOL_DESKTOP_RULE@