summaryrefslogtreecommitdiffstats
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <dvlasenk@redhat.com>2010-09-14 19:22:05 +0200
committerDenys Vlasenko <dvlasenk@redhat.com>2010-09-14 19:22:05 +0200
commitbfdf82e770def64e204d1becf9640034bcdc19bb (patch)
treee97b51dbcbab89ad8f1baa5f48754465350065a9 /src/daemon/Makefile.am
parentd34e82eb33d3f058f6600cbeccf5f2d01dcf9ff6 (diff)
downloadabrt-bfdf82e770def64e204d1becf9640034bcdc19bb.tar.gz
abrt-bfdf82e770def64e204d1becf9640034bcdc19bb.tar.xz
abrt-bfdf82e770def64e204d1becf9640034bcdc19bb.zip
This patch makes abrtd spawn a new process, abrt-server,
for every socket client. This allows for simpler timeout handling using SIGALRM, and makes timers for tracking client timeouts unnecessary. This also allows for debugging and regression testing of abrt-server separately - it can be simply run from command-line and fed commands on stdin. Also it provides a better fault isolation - crash in abrt-server does not take down abrtd. The code is based on dumpsocket.{cpp,h}. Most of dumpsocket.cpp goes to abrt-server.c, a small part goes to Daemon.cpp (i.e. to abrtd). This change will not compile - it does not have dumpsocket.cpp renamed to abrt-server.c, which makes the change easier to read. The next change, which I'll commit after this one, contains only the renaming. Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index cd69cd36..38535d1c 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -1,6 +1,6 @@
bin_SCRIPTS = abrt-debuginfo-install abrt-handle-upload
-sbin_PROGRAMS = abrtd
+sbin_PROGRAMS = abrtd abrt-server
abrtd_SOURCES = \
PluginManager.h PluginManager.cpp \
@@ -10,7 +10,6 @@ abrtd_SOURCES = \
CommLayerServer.h CommLayerServer.cpp \
CommLayerServerDBus.h CommLayerServerDBus.cpp \
Settings.h Settings.cpp \
- dumpsocket.h dumpsocket.cpp \
Daemon.h Daemon.cpp
abrtd_CPPFLAGS = \
-I$(srcdir)/../../inc \
@@ -36,6 +35,23 @@ abrtd_LDADD = \
$(RPM_LIBS) \
$(XMLRPC_LIBS) $(XMLRPC_CLIENT_LIBS)
+abrt_server_SOURCES = \
+ abrt-server.c
+abrt_server_CPPFLAGS = \
+ -I$(srcdir)/../../inc \
+ -I$(srcdir)/../../lib/utils \
+ -DBIN_DIR=\"$(bindir)\" \
+ -DVAR_RUN=\"$(VAR_RUN)\" \
+ -DCONF_DIR=\"$(CONF_DIR)\" \
+ -DDEBUG_DUMPS_DIR=\"$(DEBUG_DUMPS_DIR)\" \
+ -DDEBUG_INFO_DIR=\"$(DEBUG_INFO_DIR)\" \
+ -DPLUGINS_LIB_DIR=\"$(PLUGINS_LIB_DIR)\" \
+ -DPLUGINS_CONF_DIR=\"$(PLUGINS_CONF_DIR)\" \
+ -D_GNU_SOURCE \
+ -Wall -Werror
+abrt_server_LDADD = \
+ ../../lib/utils/libABRTUtils.la
+
dbusabrtconfdir = ${sysconfdir}/dbus-1/system.d/
dist_dbusabrtconf_DATA = dbus-abrt.conf