summaryrefslogtreecommitdiffstats
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <dvlasenk@redhat.com>2010-10-20 18:25:26 +0200
committerDenys Vlasenko <dvlasenk@redhat.com>2010-10-20 18:25:26 +0200
commitbfda214e9d634015457a7c5d8e2e1fd26d49a1fb (patch)
treeba2ae953a86e9c7715d9c98b009d72abc06820da /src/daemon/Makefile.am
parent451d3d730c7d1ff93031848882e43813ee3c346f (diff)
downloadabrt-bfda214e9d634015457a7c5d8e2e1fd26d49a1fb.tar.gz
abrt-bfda214e9d634015457a7c5d8e2e1fd26d49a1fb.tar.xz
abrt-bfda214e9d634015457a7c5d8e2e1fd26d49a1fb.zip
move logger reporting to a separate program (abrt-action-print)
Usage: abrt-action-print [v] -d DIR Print information about the crash to standard output -v, --verbose be verbose -d DIR Crash dump directory As you can see, it simply writes crash dump information to stdout, not to a file. Logger plugin spawns a child abrt-action-print -d DIR and pipes its output to log file. Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index bd839a23..06b1d44f 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -12,7 +12,8 @@ sbin_PROGRAMS = abrtd \
bin_PROGRAMS = \
abrt-action-bugzilla \
- abrt-action-rhtsupport
+ abrt-action-rhtsupport \
+ abrt-action-print
abrtd_SOURCES = \
PluginManager.h PluginManager.cpp \
@@ -200,6 +201,26 @@ abrt_action_rhtsupport_LDADD = \
../../lib/utils/libABRTdUtils.la \
../../lib/utils/libABRTUtils.la
+abrt_action_print_SOURCES = \
+ abrt-action-print.cpp
+abrt_action_print_CPPFLAGS = \
+ -I$(srcdir)/../../inc \
+ -I$(srcdir)/../../lib/utils \
+ -DBIN_DIR=\"$(bindir)\" \
+ -DVAR_RUN=\"$(VAR_RUN)\" \
+ -DCONF_DIR=\"$(CONF_DIR)\" \
+ -DLOCALSTATEDIR='"$(localstatedir)"' \
+ -DDEBUG_DUMPS_DIR=\"$(DEBUG_DUMPS_DIR)\" \
+ -DDEBUG_INFO_DIR=\"$(DEBUG_INFO_DIR)\" \
+ -DPLUGINS_LIB_DIR=\"$(PLUGINS_LIB_DIR)\" \
+ -DPLUGINS_CONF_DIR=\"$(PLUGINS_CONF_DIR)\" \
+ $(GLIB_CFLAGS) \
+ -D_GNU_SOURCE \
+ -Wall -Werror
+abrt_action_print_LDADD = \
+ ../../lib/utils/libABRTdUtils.la \
+ ../../lib/utils/libABRTUtils.la
+
dbusabrtconfdir = ${sysconfdir}/dbus-1/system.d/
dist_dbusabrtconf_DATA = dbus-abrt.conf