summaryrefslogtreecommitdiffstats
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <dvlasenk@redhat.com>2010-10-11 19:33:05 +0200
committerDenys Vlasenko <dvlasenk@redhat.com>2010-10-11 19:33:05 +0200
commit9d81201a42cbb08a14cb23abbf40ccbf26b98c49 (patch)
tree6bd231285d58e38de89656f6134d54fcc8dd3802 /src/daemon/Makefile.am
parent86cfa357aae945eac2e11ef1379c94e5ef27ccd6 (diff)
downloadabrt-9d81201a42cbb08a14cb23abbf40ccbf26b98c49.tar.gz
abrt-9d81201a42cbb08a14cb23abbf40ccbf26b98c49.tar.xz
abrt-9d81201a42cbb08a14cb23abbf40ccbf26b98c49.zip
move bugzilla reporting to a separate program (abrt-action-bugzilla)
This patch splits off Bugzilla plugin's bugzilla submission generation into a separate tool: abrt-action-bugzilla: invalid option -- 'z' Usage: abrt-action-bugzilla -c CONFFILE -d DIR [-vs] Report a crash to Bugzilla Options: -c FILE Configuration file (may be given many times) -d DIR Crash dump directory -v Verbose -s Log to syslog This change is bigger than previous similar patches: I needed to find a way to pass settings to the child and get back reporting result - all without breaking current interface. I decided to pass configuration via -c CONFFILE: (1) it is trivial to pass /etc/abrt/bugzilla.conf to it, and (2) I can use "-c -" to parse config from stdin. abrtd simply write per-reporting settings to child's stdin. The log and reporting result (success/failure) is taken from child's stdout. After a few more such patches, we can remove XMLRPC and HTTP code and library dependencies from abrtd. Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index 88da7a02..177d4f37 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -7,6 +7,9 @@ sbin_PROGRAMS = abrtd \
abrt-action-generate-backtrace \
abrt-action-save-package-data
+bin_PROGRAMS = \
+ abrt-action-bugzilla
+
abrtd_SOURCES = \
PluginManager.h PluginManager.cpp \
MiddleWare.h MiddleWare.cpp \
@@ -97,6 +100,26 @@ abrt_action_save_package_data_LDADD = \
../../lib/utils/libABRTdUtils.la \
../../lib/utils/libABRTUtils.la
+abrt_action_bugzilla_SOURCES = \
+ abrt-action-bugzilla.cpp
+abrt_action_bugzilla_CPPFLAGS = \
+ -I$(srcdir)/../../inc \
+ -I$(srcdir)/../../lib/utils \
+ -DBIN_DIR=\"$(bindir)\" \
+ -DVAR_RUN=\"$(VAR_RUN)\" \
+ -DCONF_DIR=\"$(CONF_DIR)\" \
+ -DLOCALSTATEDIR='"$(localstatedir)"' \
+ -DDEBUG_DUMPS_DIR=\"$(DEBUG_DUMPS_DIR)\" \
+ -DDEBUG_INFO_DIR=\"$(DEBUG_INFO_DIR)\" \
+ -DPLUGINS_LIB_DIR=\"$(PLUGINS_LIB_DIR)\" \
+ -DPLUGINS_CONF_DIR=\"$(PLUGINS_CONF_DIR)\" \
+ $(GLIB_CFLAGS) \
+ -D_GNU_SOURCE \
+ -Wall -Werror
+abrt_action_bugzilla_LDADD = \
+ ../../lib/utils/libABRTdUtils.la \
+ ../../lib/utils/libABRTUtils.la
+
dbusabrtconfdir = ${sysconfdir}/dbus-1/system.d/
dist_dbusabrtconf_DATA = dbus-abrt.conf