summaryrefslogtreecommitdiffstats
path: root/src/btparser/Makefile.am
diff options
context:
space:
mode:
authorKarel Klic <kklic@redhat.com>2011-03-31 12:04:31 +0200
committerKarel Klic <kklic@redhat.com>2011-03-31 12:04:31 +0200
commitf9b18646e4ed6e4a21b687cd4a99ac2b927aacfa (patch)
tree37d9f786632229e1eb7273e15d244e5988434fa3 /src/btparser/Makefile.am
parentd0c870802bb210793fc76247de65cd6a43d68517 (diff)
downloadabrt-f9b18646e4ed6e4a21b687cd4a99ac2b927aacfa.tar.gz
abrt-f9b18646e4ed6e4a21b687cd4a99ac2b927aacfa.tar.xz
abrt-f9b18646e4ed6e4a21b687cd4a99ac2b927aacfa.zip
-devel package contains btparser headers; -devel package does not include libreportgtk.so versioned libraries
Diffstat (limited to 'src/btparser/Makefile.am')
-rw-r--r--src/btparser/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/btparser/Makefile.am b/src/btparser/Makefile.am
index 030d94da..c5b0f214 100644
--- a/src/btparser/Makefile.am
+++ b/src/btparser/Makefile.am
@@ -17,6 +17,19 @@ libbtparser_la_CFLAGS = -Wall -Wwrite-strings -Werror -D_GNU_SOURCE -I../lib
libbtparser_la_LDFLAGS = -version-info 1:1:0
libbtparser_la_LIBADD = ../lib/libreport.la
+libbtparser_includedir = $(includedir)/btparser
+libbtparser_include_HEADERS = \
+ backtrace.h \
+ frame.h \
+ location.h \
+ normalize.h \
+ thread.h \
+ utils.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = btparser.pc
+EXTRA_DIST = btparser.pc.in
+
# From http://www.seul.org/docs/autotut/
# Version consists 3 numbers: CURRENT, REVISION, AGE.
# CURRENT is the version of the interface the library implements.