summaryrefslogtreecommitdiffstats
path: root/src/btparser/Makefile.am
diff options
context:
space:
mode:
authorKarel Klic <kklic@redhat.com>2010-10-14 16:36:12 +0200
committerKarel Klic <kklic@redhat.com>2010-10-14 16:36:12 +0200
commit43c74514d0faa39d343a26f39f31ec7689334b7b (patch)
tree700b3a6a06e3dc02ea94e558cdf46f25144915de /src/btparser/Makefile.am
parent704a86ddf32df845f7eca34bcb727e398dce8fa2 (diff)
downloadabrt-43c74514d0faa39d343a26f39f31ec7689334b7b.tar.gz
abrt-43c74514d0faa39d343a26f39f31ec7689334b7b.tar.xz
abrt-43c74514d0faa39d343a26f39f31ec7689334b7b.zip
btparser integration: merge it into ABRT's directory hierarchy
Diffstat (limited to 'src/btparser/Makefile.am')
-rw-r--r--src/btparser/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/btparser/Makefile.am b/src/btparser/Makefile.am
new file mode 100644
index 00000000..ceb03f3d
--- /dev/null
+++ b/src/btparser/Makefile.am
@@ -0,0 +1,44 @@
+lib_LTLIBRARIES = libbtparser.la
+libbtparser_la_SOURCES = \
+ backtrace.h backtrace.c \
+ frame.h frame.c \
+ location.h location.c \
+ normalize.h normalize.c \
+ normalize_dbus.c \
+ normalize_gdk.c \
+ normalize_glib.c \
+ normalize_glibc.c \
+ normalize_libstdcpp.c \
+ normalize_linux.c \
+ normalize_xorg.c \
+ strbuf.h strbuf.c \
+ thread.h thread.c \
+ utils.h utils.c
+libbtparser_la_CFLAGS = -Wall -Werror -D_GNU_SOURCE
+libbtparser_la_LDFLAGS = -version-info 1:1:0
+
+# From http://www.seul.org/docs/autotut/
+# Version consists 3 numbers: CURRENT, REVISION, AGE.
+# CURRENT is the version of the interface the library implements.
+# Whenever a new function is added, or its name changed, or
+# the number or type of its parameters (the prototype -- in
+# libraries we call this the function signature), this number
+# goes up. And it goes up exactly by one.
+#
+# REVISION is the revision of the implementation of this
+# interface, i.e., when you change the library by only modifying
+# code inside the functions (fixing bugs, optimizing internal
+# behavior, or adding/removing/changing signatures of functions
+# that are private to the library -- used only internally) you
+# raise the revision number only.
+#
+# Age is the difference between the newest and oldest interface
+# the library currently implements. Let's say you had 8 versions
+# of your library's interface, 0 through 7. You are now on
+# the 4th revision of the 8th interface, that is, 7:3:X (remember
+# we start counting on zero). And when you had to make choices
+# for what old interfaces you would keep support -- for backward
+# compatibility purposes, you chose to keep support for
+# interfaces 5, 6 and (obviously) the current, 7. The libtool
+# version of your library would be 7:3:2 , because the Age
+# is 7-5 = 2.