summaryrefslogtreecommitdiffstats
path: root/src/Gui/Makefile.am
diff options
context:
space:
mode:
authorJiri Moskovcak <jmoskovc@redhat.com>2009-02-25 10:22:46 +0100
committerJiri Moskovcak <jmoskovc@redhat.com>2009-02-25 10:22:46 +0100
commit5349e3c06eb12af91e89ec19d62c24712f0e8317 (patch)
tree8cfeac5691cc2fed5f573f7ae4f22dacc8edcd6f /src/Gui/Makefile.am
parent69c4a16ed61a147bedfa7de9459d4a6b9333c161 (diff)
downloadabrt-5349e3c06eb12af91e89ec19d62c24712f0e8317.tar.gz
abrt-5349e3c06eb12af91e89ec19d62c24712f0e8317.tar.xz
abrt-5349e3c06eb12af91e89ec19d62c24712f0e8317.zip
More autotools magic for gui
Diffstat (limited to 'src/Gui/Makefile.am')
-rw-r--r--src/Gui/Makefile.am26
1 files changed, 6 insertions, 20 deletions
diff --git a/src/Gui/Makefile.am b/src/Gui/Makefile.am
index 23d0571a..6c3b6094 100644
--- a/src/Gui/Makefile.am
+++ b/src/Gui/Makefile.am
@@ -1,29 +1,15 @@
#SUBDIRS=gui tui plugins tests conf
-#bin_SCRIPTS = mainwindow.py
+bin_SCRIPTS = cc-gui
-PYTHON_FILES = CCDBusBackend.py CCDumpList.py CCDump.py CC_gui_functions.py ccgui.glade CCReporterDialog.py mainwindow.py
+PYTHON_FILES = CCDBusBackend.py CCDumpList.py CCDump.py CC_gui_functions.py ccgui.glade CCReporterDialog.py CCMainWindow.py
GLADE_FILES = ccgui.glade
EXTRA_DIST = $(PYTHON_FILES) $(GLADE_FILES)
-ccguidir = $(pkgdatadir)
-ccgui_PYTHON = $(PYTHON_FILES)
-ccgui_DATA = $(GLADE_FILES)
+#ccguidir = $(pkgdatadir)
+pkgdata_PYTHON = $(PYTHON_FILES)
+pkgdata_DATA = $(GLADE_FILES)
-execdir = $(sbindir)
-
-CLEANFILES := $(notdir $(wildcard *~)) $(notdir $(wildcard *\#)) $(notdir $(wildcard \.\#*)) $(notdir $(wildcard *.pyc))
-
-check-local:
- @for i in $(notdir $(wildcard *.py)); do echo $(PYTHON_FILES)|grep -q $$i || (echo $$i is missing;false) || exit 1;done && echo "Source file check PASSED"
-install-exec-local:
- mkdir -p $(DESTDIR)$(pkgdatadir) $(DESTDIR)$(sbindir) $(DESTDIR)$(bindir)
- install -m 0755 $(srcdir)/mainwindow.py $(DESTDIR)$(pkgdatadir)
- ln -fs $(pkgdatadir)/mainwindow.py $(DESTDIR)$(bindir)/crash-catcher-gui
-uninstall-local:
- rm -fr $(DESTDIR)$(pkgdatadir)
- rm -f $(DESTDIR)$(bindir)/crash-catcher-gui
-
- \ No newline at end of file
+CLEANFILES := $(notdir $(wildcard *~)) $(notdir $(wildcard *\#)) $(notdir $(wildcard \.\#*)) $(notdir $(wildcard *.pyc)) \ No newline at end of file