summaryrefslogtreecommitdiffstats
path: root/src/Gui/Makefile.am
diff options
context:
space:
mode:
authorJiri Moskovcak <jmoskovc@redhat.com>2010-07-19 17:42:36 +0200
committerJiri Moskovcak <jmoskovc@redhat.com>2010-07-19 18:02:13 +0200
commit34341440f155a79f792ba35edba9dbc429b77850 (patch)
tree0c502244e73502b55b7272c8c66496193f77da1b /src/Gui/Makefile.am
parentcb192958219286cdf816e152c4184e649c56fdce (diff)
downloadabrt-34341440f155a79f792ba35edba9dbc429b77850.tar.gz
abrt-34341440f155a79f792ba35edba9dbc429b77850.tar.xz
abrt-34341440f155a79f792ba35edba9dbc429b77850.zip
fixed tooltip localization rhbz#574693
Diffstat (limited to 'src/Gui/Makefile.am')
-rw-r--r--src/Gui/Makefile.am21
1 files changed, 9 insertions, 12 deletions
diff --git a/src/Gui/Makefile.am b/src/Gui/Makefile.am
index 1588b1f0..002b3bc7 100644
--- a/src/Gui/Makefile.am
+++ b/src/Gui/Makefile.am
@@ -1,5 +1,3 @@
-#SUBDIRS=gui tui plugins tests conf
-
bin_SCRIPTS = abrt-gui
PYTHON_FILES = CCDBusBackend.py CCDumpList.py CCDump.py CC_gui_functions.py \
@@ -11,20 +9,19 @@ PYTHON_FILES = CCDBusBackend.py CCDumpList.py CCDump.py CC_gui_functions.py \
GLADE_FILES = ccgui.glade report.glade settings.glade dialogs.glade \
settings_wizard.glade progress_window.glade
-EXTRA_DIST = $(PYTHON_FILES) $(GLADE_FILES) abrt-gui abrt.desktop
-
-#ccguidir = $(pkgdatadir)
-applicationsdir = $(datadir)/applications
-applications_DATA = abrt.desktop
pkgdata_PYTHON = $(PYTHON_FILES)
pkgdata_DATA = $(GLADE_FILES)
-#pixmapdir = $(datadir)/icons/hicolor/48x48/apps/
-#pixmap_DATA = abrt.png
-CLEANFILES := $(notdir $(wildcard *~)) $(notdir $(wildcard *\#)) $(notdir $(wildcard \.\#*)) $(notdir $(wildcard *.pyc))
+@INTLTOOL_DESKTOP_RULE@
+
+desktopdir = $(datadir)/applications
+desktop_in_files = abrt.desktop.in
-abrt.desktop:
- intltool-merge -d ../../po abrt.desktop.in abrt.desktop
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+
+EXTRA_DIST = $(PYTHON_FILES) $(GLADE_FILES) abrt-gui $(desktop_in_files)
+
+CLEANFILES := $(notdir $(wildcard *~)) $(notdir $(wildcard *\#)) $(notdir $(wildcard \.\#*)) $(notdir $(wildcard *.pyc))
install-exec-hook:
for b in $(bin_SCRIPTS); do \